【P1825 [USACO11OPEN] Corn Maze S】

[USACO11OPEN] Corn Maze S

题面翻译

奶牛们去一个 N × M N\times M N×M 玉米迷宫, 2 ≤ N ≤ 300 , 2 ≤ M ≤ 300 2 \leq N \leq 300,2 \leq M \leq300 2N300,2M300

迷宫里有一些传送装置,可以将奶牛从一点到另一点进行瞬间转移。这些装置可以双向使用。

如果一头奶牛处在这个装置的起点或者终点,这头奶牛就必须使用这个装置。

玉米迷宫除了唯一的一个出口都被玉米包围。

迷宫中的每个元素都由以下项目中的一项组成:

  1. 玉米,# 表示,这些格子是不可以通过的。
  2. 草地,. 表示,可以简单的通过。
  3. 传送装置,每一对大写字母 A \tt{A} A Z \tt{Z} Z 表示。
  4. 出口,= 表示。
  5. 起点, @ 表示

奶牛能在一格草地上可能存在的四个相邻的格子移动,花费 1 1 1 个单位时间。从装置的一个结点到另一个结点不花时间。

题目描述

This past fall, Farmer John took the cows to visit a corn maze. But this wasn’t just any corn maze: it featured several gravity-powered teleporter slides, which cause cows to teleport instantly from one point in the maze to another. The slides work in both directions: a cow can slide from the slide’s start to the end instantly, or from the end to the start. If a cow steps on a space that hosts either end of a slide, she must use the slide.

The outside of the corn maze is entirely corn except for a single exit.

The maze can be represented by an N x M (2 <= N <= 300; 2 <= M <= 300) grid. Each grid element contains one of these items:

* Corn (corn grid elements are impassable)

* Grass (easy to pass through!)

* A slide endpoint (which will transport a cow to the other endpoint)

* The exit

A cow can only move from one space to the next if they are adjacent and neither contains corn. Each grassy space has four potential neighbors to which a cow can travel. It takes 1 unit of time to move from a grassy space to an adjacent space; it takes 0 units of time to move from one slide endpoint to the other.

Corn-filled spaces are denoted with an octothorpe (#). Grassy spaces are denoted with a period (.). Pairs of slide endpoints are denoted with the same uppercase letter (A-Z), and no two different slides have endpoints denoted with the same letter. The exit is denoted with the equals sign (=).

Bessie got lost. She knows where she is on the grid, and marked her current grassy space with the ‘at’ symbol (@). What is the minimum time she needs to move to the exit space?

输入格式

第一行:两个用空格隔开的整数 N N N M M M

2 ∼ N + 1 2\sim N+1 2N+1 行:第 i + 1 i+1 i+1 行描述了迷宫中的第 i i i 行的情况(共有 M M M个字符,每个字符中间没有空格)。

输出格式

一个整数,表示起点到出口所需的最短时间。

样例 #1

样例输入 #1

5 6
###=##
#.W.##
#.####
#.@W##
######

样例输出 #1

3

提示

例如以下矩阵, N = 5 , M = 6 N=5,M=6 N=5,M=6

###=##
#.W.##
#.####
#.@W##
######

唯一的一个装置的结点用大写字母 W \tt{W} W 表示。

最优方案为:先向右走到装置的结点,花费一个单位时间,再到装置的另一个结点上,花费 0 0 0 个单位时间,然后再向右走一个,再向上走一个,到达出口处,总共花费了 3 3 3 个单位时间。

与普通的BFS最大的不同就是有了传送门这个东西,从一个进去后就会到达另一个相对应的字母,和我们玩的森林冰火人一样的那种传送门,所以问题的核心就成了如何解决这个“传送门”,我们想到用一个结构体来实现
在这里插入图片描述
具体怎么实现的呢?

实现

在这里插入图片描述

#include<bits/stdc++.h>
using namespace std;
const int N=305;
char g[N][N];
int n,m;
struct node{
	int x,y,cnt;
};
struct chuan{
	int x1,x2,y1,y2;
}ma[100];
int dx[4]={-1,0,1,0},dy[4]={0,1,0,-1};
queue<node> q;
int main()
{
	cin>>n>>m;
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=m;j++)
		{
			cin>>g[i][j];
			if(g[i][j]>='A'&&g[i][j]<='Z')
			{
				if(ma[g[i][j]].x1==0&&ma[g[i][j]].y1==0)ma[g[i][j]].x1=i,ma[g[i][j]].y1=j;
				else ma[g[i][j]].x2=i,ma[g[i][j]].y2=j;
			}else if(g[i][j]=='@'){
				q.push(node{i,j,0});
				
				g[i][j]='#';
			}
		}
	}
	while(!q.empty())
	{
		node p=q.front();
		q.pop();
		for(int i=0;i<4;i++)
		{
			int x=p.x+dx[i],y=p.y+dy[i];
			if(x<1||y<1||x>n||y>m||g[x][y]=='#')continue;
			if(g[x][y]=='.')
			{
				g[x][y]='#';
				q.push(node{x,y,p.cnt+1});
				continue;
			}
			if(g[x][y]=='=')
			{
				cout<<p.cnt+1;
				return 0;
			}
			if(ma[g[x][y]].x1==x&&ma[g[x][y]].y1==y)
			q.push(node{ma[g[x][y]].x2,ma[g[x][y]].y2,p.cnt+1});
			else q.push(node{ma[g[x][y]].x1,ma[g[x][y]].y1,p.cnt+1});
		}
	}
	return 0;
}

ps:本人也借鉴了哔哩哔哩上的一个up主的讲解视频

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Marshuo.O

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值