湖南大学实训2-8:Engine-字符串

【问题描述】

       谷歌、百度等搜索引擎已经成为了互连网中不可或缺的一部分。在本题中,你的任务也是设计一个搜索论文的搜索引擎,当然,本题的要求比起实际的需求要少了许多。
       本题的输入将首先给出一系列的论文,对于每篇论文首先给出标题,然后给出它被引用的次数。然后会有一系列的搜索询问,询问标题中包含特定关键词的论文有哪些。
       每一个询问可能包含多个关键词,你需要找出标题包含所有关键词的论文。
    “包含”必须是标题中有一个词正好是给定的关键词,不区分大小写。
      对每个询问,都按被引用的次数从多到少输出满足条件的论文的标题。如果有被引用的次数相同的论文,则按照论文在输入中的顺序排列,先给出的论文排在前面。

【输入形式】

输入包含多组数据。
     每组数据首先有一行包含一个整数N(1<=N<=1000),表示论文的数目,N=0表示输入结束。每组论文的信息第一行是论文的标题,由字母(大小写均可)和空格组成,不超过10个词,每个词不超过20个字符,标题总共不超过250个字符。第二行是一个整数K(0<=K&lt;=108),表示它被引用的次数。在论文信息结束以后,有一行包含一个整数M(1<=M<=100),表示询问的数目。接下来有M行,每行是一个询问,由L(1<=L<=10)个空格分开的词构成,每个词不超过20个字符。

【输出形式】

      对每个询问,按照题目给定的顺序输出满足条件的论文的标题;如果没有满足条件的论文,就不输出。在每组询问的输出之后输出一行“***”,在每组数据的输出之后输出一行“---”。

【样例输入1】

6
Finding the Shortest Path
120
Finding the k Shortest Path
80
Find Augmenting Path in General Graph
80
Matching in Bipartite Graph
200
Finding kth Shortest Path
50
Graph Theory and its Applications
40
6
shortest path
k shortest path
graph
path
find
application
0

【样例输出1】

Finding the Shortest Path
Finding the k Shortest Path
Finding kth Shortest Path
***
Finding the k Shortest Path
***
Matching in Bipartite Graph
Find Augmenting Path in General Graph
Graph Theory and its Applications
***
Finding the Shortest Path
Finding the k Shortest Path
Find Augmenting Path in General Graph
Finding kth Shortest Path
***
Find Augmenting Path in General Graph
***

***
---

【样例输入2】

1
Finding the Shortest Path
120
2
Path

Pat
0

【样例输出2】

Finding the Shortest Path

***

***

---

【样例说明】

需要查询的内容为“k shortest path”,他包含了3个独立的关键词。

【AC代码】

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int n;
struct article{
	string title,low_title;
	int cnt;
};
vector<article> vec;

bool cmp(const article &a,const article &b)
{
	return a.cnt>b.cnt;
}

string to_low(string s)
{
	int len=s.length();
	for(int i=0;i<len;i++){
		if(s[i]>='A'&&s[i]<='Z'){
			s[i]+=32;
		}
	}
	return s;
}

vector<string> split_keyword(string ss)
{
	vector<string> res;
	int len=ss.length();
	int qian=0;
	for(int i=0;i<len;i++){
		if(ss[i]==' '){
			res.push_back(ss.substr(qian,i-qian));
			qian=i+1;
		}
	}
	res.push_back(ss.substr(qian));
	return res;
}

void solve()
{
	vec.clear();
	for(int i=1;i<=n;i++){
		article t;
		getchar();
		getline(cin,t.title);
		cin>>t.cnt;
		t.low_title=to_low(t.title);
		vec.push_back(t);
	}
	sort(vec.begin(),vec.end(),cmp);
	
	int m;
	cin>>m;
	getchar();
	
	while(m--){
		string ss;
		getline(cin,ss);
		vector<string> words=split_keyword(ss);
		int num=words.size();
		
		/* 查询 */
		for(vector<article>::iterator ip=vec.begin();ip!=vec.end();ip++){
			int temp=0;
			for(vector<string>::iterator it=words.begin();it!=words.end();it++){
				string::size_type findword=ip->low_title.find(*it);
				int len=(*it).length();
				if(findword!=string::npos){
					/* 找到的keyword在title中必须独立存在 不能是某个单词的一部分 */
					if(findword==0&&ip->low_title[findword+len]==' ') temp++;
					else if(findword!=0&&ip->low_title[findword-1]==' '&&(ip->low_title[findword+len]==' '||ip->low_title[findword+len]=='\0')) temp++;
				}
			}
			if(temp==num) cout<<ip->title<<endl;
		}
		cout<<"***"<<endl;
	}
	cout<<"---"<<endl;
}

int main()
{
	while(cin>>n&&n!=0) solve();
	return 0; 
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Awars_zpp

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值