枚举型习题(1):输入整数输出其对应的颜色

Description

已知枚举类型定义如下:
enum
{
red, yellow, blue, green, black, white
};
从键盘输入一整数,显示与该整数对应的枚举常量的英文名称。

Input

输入仅一行,输入一个整数(0~5之间)

Output

输出仅一行,输出数字所对应的颜色单词

Sample Input

1

Sample Output

yellow

Source

#include  <stdio.h>

int  main()

{

    enum  color

    {

        red=0, yellow, blue, green, black, white

    }col;

    int  i;

    scanf("%d",&i);

    col=(enum  color)i;

    switch (col)

    {

    case  0:printf("red");

    break;

    case  1:printf("yellow");

    break;

    case  2:printf("blue");

    break;

    case  3:printf("green");

    break;

    case  4:printf("black");

    break;

    case  5:printf("white");

    break;

    }

    system("pause");

    return  0;

}

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值