指针习题(2):编写字符串连接函数strcat()

Description

编写函数实现字符串连接函数strcat( )的功能。

Input

输入仅一行,输入两个字符串。

Output

输出仅一行,输出连接后的一个字符串。

Sample Input

abc   defgh

Sample Output

abcdefgh

Source

#include  <stdio.h>

int  main()

{

    char  a[20],b[20];

    scanf("%s%s",a,b);

    int  i,j;

    i=0;

    while (a[i])

    {

        i++;

    }

    j=0;

    while (b[j])

    {

        a[i]=b[j];

        i++;

        j++;

    }

    a[i]='\0';

    printf("%s",a);

    system("pause");

    return  0;

}

  • 4
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值