PAT Advanced Level 1003:Emergency

1003. Emergency (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4


教训:

1.不管怎么样,变量最好赋初值,像下面的k,没有赋初值,如果g.N=1的时候,k就没有被赋到值,结果set[k]中的k是任何可能的值,造成段错误。

2.做题的时候要考虑到边界的案例

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int INF=0x2FFFFFFF;
struct MGraph{
    int p[505][505];
    int N,M;
    int v[505];//每个城市的救援队数量
    int c[505];//统计到剩余结点最短距离相等路径的条数
    int w[505];//统计到剩余结点的最大救援的人数
}g;
void dijkstra(int s,int dist[],int path[]){
    int set[505],i,j,min,k;//set是标记数组,min是通往剩余顶点最短的距离,k是最短的距离的那个点的id
    for(i=0;i<g.N;i++){
        dist[i]=g.p[s][i];
        set[i]=0;
        g.c[i]=1;
        if(g.p[s][i]<INF){
            path[i]=s;
            g.w[i]=g.v[s]+g.v[i];//直连的直接用开始结点的加上该结点
        }else{
            path[i]=-1;
        }
    }
    set[s]=1;
    path[s]=-1;
    for(i=0;i<g.N;i++){
        min=INF;
        //找最小值
        for(j=0;j<g.N;j++){
            if(set[j]==0&&dist[j]<min){
                k=j;                
                min=dist[j];
            }
        }
        set[k]=1;//标记已访问过
        for(j=0;j<g.N;j++){
            if(set[j]==0&&dist[k]+g.p[k][j]<=dist[j])//原来INF是定成最大的数0x7FFFFFFF,结果要是加上1就变成-1,这句<dist[j]会通过,卡了我好久
            {
                if(dist[k]+g.p[k][j]==dist[j])//路径长度相等的话
                {
                    g.c[j]=g.c[k]+g.c[j];
                    if(g.w[k]+g.v[j]>g.w[j])//在最短路径相等的情况下,选择救援队最多的那条
                    {
                        g.w[j]=g.w[k]+g.v[j];
                        dist[j]=dist[k]+g.p[k][j];
                        path[j]=k; 
                    }
                }else{
                    g.w[j]=g.w[k]+g.v[j];
                    g.c[j]=g.c[k];
                    dist[j]=dist[k]+g.p[k][j];
                    path[j]=k;
                }
            }
        }
    }
}
int main(){
   // freopen("input.txt","r",stdin);
    int C1,C2,i,j,sum=0;
    int dist[505];
    int path[505];
    scanf("%d%d%d%d",&g.N,&g.M,&C1,&C2);
    for(i=0;i<g.N;i++){
        scanf("%d",&g.v[i]);
        for(j=0;j<g.N;j++){
            if(i==j){
                g.p[i][j]=0;
            }else{
                g.p[i][j]=INF;
            }
        }
    }

    if(g.M==0){
        printf("1 %d",g.v[0]);
        return 0;
    }

    while(g.M--){
        int m,n;
        scanf("%d%d",&m,&n);
        scanf("%d",&g.p[m][n]);
        g.p[n][m]=g.p[m][n];
    }
    dijkstra(C1,dist,path);
    printf("%d ",g.c[C2]);
    printf("%d",g.w[C2]);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值