poj 2828 Buy Tickets

很简单的线段树,主要是弄清与原理,每个点保存的是这一段区间还有多少个空位置,把这个想明白了,所有的就都简单了!

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The nextN lines contain the pairs of valuesPosi andVali in the increasing order ofi (1 ≤iN). For each i, the ranges and meanings ofPosi andVali are as follows:

  • Posi ∈ [0, i − 1] — Thei-th person came to the queue and stood right behind thePosi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — Thei-th person was assigned the valueVali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

 

 

 

#include <iostream>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <algorithm>

#define lson l,m,rt<<1      //左儿子
#define rson m+1,r,rt<<1|1  //右儿子

using namespace std;

int n;//数据个数
int tree[200010*4];//树的节点的个数,按理来说*3 应该是够了,但是*4是notonlysuccess说的
int pos[200010];//每个人插入的位置
int value[200010];//每个人的价值
int id;//最后标记使用
int ans[200010];

void bulid(int l,int r,int rt)//建树
{
    tree[rt]=r-l+1;
    if(l==r)
        return;
    int m=(l+r)>>1;
    bulid(lson);
    bulid(rson);
}

void update(int p,int l,int r,int rt)
{
    tree[rt]--;
    if(l==r)
    {
        id=l;
        return;
    }
    int m=(l+r)>>1;
    if(tree[rt<<1]>=p)
        update(p,lson);
    else
    {
        p-=tree[rt<<1];
        update(p,rson);
    }
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        bulid(1,n,1);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",pos+i,value+i);
        }
        for(int i=n;i>=1;i--)
        {
            update(pos[i]+1,1,n,1);
            ans[id]=value[i];
        }
        for(int i=1;i<n;i++)
            printf("%d ",ans[i]);
        printf("%d\n",ans[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值