hdu 4430 Yukari's Birthday

博客探讨了HDU 4430 Yukari's Birthday问题的解决方案,主要涉及枚举r和二分k的算法思路。文章中作者提到在实现过程中遇到的一个难点,即在判断相等条件时出现的加一操作,表示对此存在疑问并邀请读者讨论。
摘要由CSDN通过智能技术生成
Problem Description
Today is Yukari's n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it's a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time, though she herself insists that she is a 17-year-old girl.
To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place k i candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it's optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.

Input
There are about 10,000 test cases. Process to the end of file.
Each test consists of only an integer 18 ≤ n ≤ 10 12.

Output
For each test case, output r and k.

Sample Input
  
  
18 111 1111

Sample Output
1 17
2 10
3 10

枚举r,二分k

这个地方有个地方,我也弄不懂  为啥最后判断相等的时候会有一个加一的操作

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <cmath>
using namespace std;

__int64 br,k,n;
__int64 sum;
__int64 temp;
__int64 t;
__int64 x,y;

__int64 getk()//二分一个k
{
    t=(__int64)pow(n*1.0,1.0/br);
    __int64 mid,left,right;
    left=2;
    right=t;
    while(left<=right)
    {
        mid=(left+right)>>1;
        __int64 ans=0;
        __int64 res=1;
        for(int i=1;i<=br;i++)
        {
            res*=mid;
            if(n<res)
            {
                ans=n+1;
                right=mid-1;
                break;
            }
            ans+=res;
            if(n<ans)
            {
                right=mid-1;
                break;
            }
        }
        if(ans==n||ans+1==n)//这个地方为什么是这样的,我也不知道,WA了十几次,看了别人这样写,也改了一下,竟然A了
        {
            return mid;
        }
        if(ans<n)
        {
            left=mid+1;
        }
    }
    return 0;
}
int main()
{
    while(scanf("%I64d",&n)!=EOF)
    {
        sum=1e19;
        x=1e19;
        y=1e19;
        for(br=1;br<=60;br++)//这个地方枚举r
        {
            //二分一个k
            temp=getk();
            if(temp==0)
                continue;
            if(sum>br*temp)
            {
                sum=br*temp;
                x=br;
                y=temp;
            }
            if(sum==br*temp)
            {
                if(x>br)
                {
                    x=br;
                    y=temp;
                }
            }
        }
        printf("%I64d %I64d\n",x,y);
    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值