poj 3468 A Simple Problem with Integers

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

 

题目对于初学者来说,有点难,主要考察的是成段更新,用到了懒惰标记,做起来还是很好玩的

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;

#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define LL long long
#define M  100005

LL add[M<<2];
LL sum[M<<2];


void PushUp(int rt)//求区间和
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}

void PushDown(int rt,int m)//向下更新
{
    if(add[rt])
    {
        add[rt<<1]+=add[rt];
        add[rt<<1|1]+=add[rt];
        sum[rt<<1]+=add[rt]*(m-(m>>1));
        sum[rt<<1|1]+=add[rt]*(m>>1);
        add[rt]=0;
    }
    return;
}

void build(int l,int r,int rt)//建树
{
    if(l==r)
    {
        scanf("%lld",&sum[rt]);
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    PushUp(rt);//区间求和
}

LL query(int x,int y,int l,int r,int rt)//求和操作
{
    if(x<=l&&r<=y)
    {
        return sum[rt];
    }
    PushDown(rt,r-l+1);//这个地方很重要,向下更新
    int m=(l+r)>>1;
    LL ret=0;
    if(x<=m)
         ret+=query(x,y,lson);
    if(m<y)
         ret+=query(x,y,rson);
    return ret;//在次WA两次
}

void update(int x,int y,int z,int l,int r,int rt)
{
    if(x<=l&&r<=y)
    {
        add[rt]+=(LL)z;
        sum[rt]+=(LL)z*(r-l+1);
        return;
    }
    PushDown(rt,r-l+1);//懒惰标记的体现
    int m=(l+r)>>1;
    if(x<=m)
        update(x,y,z,lson);
    if(m<y)
        update(x,y,z,rson);
    PushUp(rt);//更新之后的区间和
}
int main()
{
    int n,q;
    char ch[2];
    int x,y,z;
    while(scanf("%d%d",&n,&q)!=EOF)
    {
        memset(add,0,sizeof(add));
        memset(sum,0,sizeof(sum));
        build(1,n,1);
        for(int i=1;i<=q;i++)
        {
            scanf("%s",ch);
            if(ch[0]=='Q')
            {
                scanf("%d%d",&x,&y);
                printf("%lld\n",query(x,y,1,n,1));
            }
            else
            {
                scanf("%d%d%d",&x,&y,&z);
                update(x,y,z,1,n,1);
            }
        }
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值