STL初步 lower_bound & upper_bound UVa 10474

STL初步

lower_bound & upper_bound

UVa 10474

Sample Input
4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0

Sample Output
CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=10000;

int main()
{
    int n,q,x,a[maxn],kase=0;
    while(scanf("%d%d",&n,&q)==2&&n)
    {
        printf("CASE# %d:\n",++kase);
        for(int i=0;i<n;i++)scanf("%d",&a[i]);
        sort(a,a+n);
        while(q--)
        {
            scanf("%d",&x);
            int p=lower_bound(a,a+n,x)-a;//lower_bound(上界,下界 ,x)  查找大于或等于x的第一个位置(从0开始)
            /*
            int p=upper_bound(a,a+n,x)-a;

            函数upper_bound()返回的在前闭后开区间查找的关键字的上界,
            如一个数组number序列1,2,2,4.upper_bound(2)后,返回的位置是3(下标)也就是4所在的位置,(lower为1)
            同样,如果插入元素大于数组中全部元素,返回的是last。(注意:此时数组下标越界!!)
             返回查找元素的最后一个可安插位置,也就是“元素值>查找值”的第一个元素的位置
            */
            if(a[p]==x)printf("%d found at %d\n",x,p+1);
            else printf("%d not found\n",x);
        }
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值