Common Subsequence

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8076    Accepted Submission(s): 3231


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
 
  
abcfbc abfcab programming contest abcd mnp
 
Sample Output
 
  
4 2 0
貌似太简单的中文题都做完了,汗~今天这两道题真不顺呀。
刚开始尝试着暴力解一下,结果显然超时了。后来在使用dp写的时候,动态方程没列好,老是结果不对,数组越界,搞的本来都不转的脑子直接卡死了。吃了点爆米花才缓过来。
设两个字符串为a[]b[],dp[i][j]为a取前i个,b取前j个字符时的最大公共子序列。
动态方程:
if(a[i]==b[j]) dp[i][j]=dp[i-1][j-1]+1;
else dp[i][j]=(dp[i][j-1]>p[j][i-1]?dp[i][j-1]:p[j][i-1]);
初始化时a[i][0]=a[0][j]=0;
下面是AC代码:
#include<iostream>
using namespace std;
char a[2010];
char b[2010];
int dp[2010][2010];
int main(){
while(scanf("%s%s",a,b)!=EOF){
int a1=strlen(a);
int b1=strlen(b);
for(int i=0;i<a1;i++){
dp[i][0]=0;
}
for(int i=0;i<b1;i++){
dp[0][i]=0;
}
for(int i=1;i<a1+1;i++){
for(int j=1;j<b1+1;j++){
if(a[i-1]==b[j-1]){
dp[i][j]=dp[i-1][j-1]+1;
}
else{
dp[i][j]=dp[i-1][j]>dp[i][j-1]?dp[i-1][j]:dp[i][j-1];
}
}
}
cout<<dp[a1][b1]<<endl;
}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值