1010 Radix (25分)

题目链接:1010 Radix
题目:
Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N
​1
​​ and N
​2
​​ , your task is to find the radix of one number while that of the other is given.

Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10

Sample Output 1:
2

Sample Input 2:
1 ab 1 2

Sample Output 2:
Impossible

解题思路

将两个数都转化为用0~9表示的int数后,已知进制的数a保留其原始进制不变,然后根据两个数当前显示的大小(暂且都看成是十进制),对未知进制的数b进行进制枚举,直至一个进制转换后的一个数==a为止

需要注意的地方:

1、将进制转化单独写一个函数方便调用
2、查找进制时需要明确其上限(并不是1~36)的范围
3、查找的方法如果使用暴力循环,会有一个测试点超时,所以考虑采用二分查找。
代码如下:

#include<iostream>
#include<string>
#include<cctype>
#include<algorithm>
#include<cmath>
using namespace std;
//进制转换 
long long convert(string num, long long radix)
{
	long long ans = 0;
	reverse(num.begin(), num.end());
	for(int i=0; i<num.size(); i++)
	{
		if(num[i] <= '9')
			ans += (num[i] - '0') * pow(radix, i);
		else 
			ans += (num[i] - 'a' + 10) * pow(radix, i);
	}
	return ans;
}

long long getRadix(string str, long long num)
{
	long long result_radix = -1;
	char it = *max_element(str.begin(), str.end());
	long long low = (isdigit(it)?it-'0':it-'a'+10)+1;
	long long high = max(low, num);
	while(low<=high)
	{
		long long mid = (low + high)/2;
		long long temp = convert(str, mid);
		if(temp > num || temp < 0)
			high = mid-1;
		else if(temp < num)
			low = mid + 1;
		else
		{
			result_radix = mid;
			break;
		}
	}
	return result_radix;
}

int main()
{
	string a, b;
	int tag;
	long long radix;
	
	cin>>a>>b>>tag>>radix;

	long long n1 = convert(a, radix);
	long long n2 = convert(b, radix);
	
	long long known_num = (tag == 1? n1:n2);
	long long result = getRadix((tag == 1?b:a), known_num);
	if(result !=-1)
		cout<<result;
	else 
		cout<<"Impossible";
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值