【POJ】3208Apocalypse Someday-数位dp+二分

Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 2198 Accepted: 1107

Description

The number 666 is considered to be the occult “number of the beast” and is a well used number in all major apocalypse themed blockbuster movies. However the number 666 can’t always be used in the script so numbers such as 1666 are used instead. Let us call the numbers containing at least three contiguous sixes beastly numbers. The first few beastly numbers are 666, 1666, 2666, 3666, 4666, 5666…

Given a 1-based index n, your program should return the nth beastly number.

Input

The first line contains the number of test cases T (T ≤ 1,000).

Each of the following T lines contains an integer n (1 ≤ n ≤ 50,000,000) as a test case.

Output

For each test case, your program should output the nth beastly number.

Sample Input

3
2
3
187

Sample Output

1666
2666
66666

Source

POJ Monthly--2007.03.04, Ikki, adapted from TCHS SRM 2 ApocalypseSomeday

题目大意:给定n,输出第n大包含666的数字。

 

思路:基本的数位dp先求解出各个数值中的有多少个含有666的,然后二分求解答案

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 22
#define ll long long
using namespace std;
ll a[maxn],dp[maxn][maxn],n;

ll dfs(ll pos,ll pre,bool limit)
{
    if(pos==-1) return pre==3;
    if(!limit&&dp[pos][pre]!=-1)
        return dp[pos][pre];
    ll ans=0,nextp,up;
    up=limit?a[pos]:9;

    for(int i=0;i<=up;i++)
    {
        if(pre==3) nextp=3;
        else if(pre==2&&i==6) nextp=3;
        else if(pre==1&&i==6) nextp=2;
        else if(pre==0&&i==6) nextp=1;
        else nextp=0;

        ans+=dfs(pos-1,nextp,limit&&(i==up));
    }
    if(!limit) dp[pos][pre]=ans;
    return ans;

}

ll calc(ll x){
    memset(dp,-1,sizeof(dp));
    ll pos = 0;
    while(x){
        a[pos ++] = x%10;
        x /= 10;
    }
    return dfs(pos - 1, 0 ,1);
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        ll l = 666LL,mid;
        ll r = 100000000000LL;
        while(l < r){
            mid = (l + r)/2;
            ll temp = calc(mid);
            if(temp >= n) r = mid;
            else l = mid + 1;
        }
        cout<<l<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值