【POJ】Tram(Floyd改变路的指向)

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 19904 Accepted: 7428

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch. 

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually. 

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B. 

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N. 

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed. 

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0

Source

Croatia OI 2002 Regional - Juniors

题意:

        一张图中,每个结点一开始都指向了一个相邻点。可以改变每个点指向的点。求一条从A到B的路,使用最少改变路上点的指向的次数,若不存在输出-1。

思路:

       i指向j,则dist[i][j] = 0。

       若i能通过改变方向指向j的话, dist[i][j]=1。

       否则dist[i][j]=INF。
 

#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 1e9
using namespace std;
const int maxn= 100+10;
int n,a,b;
int d[maxn][maxn];
int main()
{
    while(scanf("%d%d%d",&n,&a,&b)==3)
    {
        for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            d[i][j] = i==j?0:INF;
        for(int i=1;i<=n;i++)
        {
            int k,u;
            scanf("%d",&k);
            for(int j=1;j<=k;j++)
            {
                scanf("%d",&u);
                if(j==1) d[i][u]=0;
                else d[i][u]=1;
            }
        }
        for(int k=1;k<=n;k++)
        for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            d[i][j] = min(d[i][j],d[i][k]+d[k][j]);
 
        printf("%d\n",d[a][b]==INF?-1:d[a][b]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值