poj1305毕达哥拉斯三元组

Language:
Fermat vs. Pythagoras
Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 1431 Accepted: 834

Description

Computer generated and assisted proofs and verification occupy a small niche in the realm of Computer Science. The first proof of the four-color problem was completed with the assistance of a computer program and current efforts in verification have succeeded in verifying the translation of high-level code down to the chip level. 
This problem deals with computing quantities relating to part of Fermat's Last Theorem: that there are no integer solutions of a^n + b^n = c^n for n > 2. 
Given a positive integer N, you are to write a program that computes two quantities regarding the solution of x^2 + y^2 = z^2, where x, y, and z are constrained to be positive integers less than or equal to N. You are to compute the number of triples (x,y,z) such that x < y < z, and they are relatively prime, i.e., have no common divisor larger than 1. You are also to compute the number of values 0 < p <= N such that p is not part of any triple (not just relatively prime triples). 

Input

The input consists of a sequence of positive integers, one per line. Each integer in the input file will be less than or equal to 1,000,000. Input is terminated by end-of-file

Output

For each integer N in the input file print two integers separated by a space. The first integer is the number of relatively prime triples (such that each component of the triple is <=N). The second number is the number of positive integers <=N that are not part of any triple whose components are all <=N. There should be one output line for each input line.

Sample Input

10
25
100

Sample Output

1 4
4 9
16 27

Source




题意:求1~n之间x^2+y^2=z^2且x,y,z互素有多少组,和不含x^2+y^2=z^2的数的个数。

分析:刚学数论,该式子的x,y,z构成毕达哥拉斯三元组,其中两两互素的成为本原毕达哥拉斯三元组,对于本原毕达哥拉斯三元组有一个构造定理:当且仅当y为偶数且存在两个正整数m和n互素,m和n奇偶互异则

x = m*m-n*n

y = 2*m*n;

z = m*m+n*n; (x, y, z)为本原毕达哥拉斯三元组

对于本题最多枚举到√n即可时间复杂度为(n*k)k为询问次数,本题还卡空间,刚开始MLE了,需要优化一下


#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <cctype>
#include <algorithm>

using namespace std;

const int maxn = 1000000 + 5;
int p[maxn];
bool vis[maxn];

int gcd(int a, int b)
{
	return b == 0 ? a : gcd(b, a%b);
}
void query(int num)
{
    p[0] = 0;
    int sum = 0;
    memset(vis, 0, sizeof(vis));
    memset(p, 0, sizeof(p));
    int mmax = (int)sqrt(1.0*num);
    for (int m = 1; m <= mmax; m++)
    {
        for (int n = 1; n < m; n++)
        {

        	if (gcd(m, n) != 1) continue;
        	if ((m%2==0&&n%2==0)||(n%2==1&&m%2==1)) continue;
            int x = m*m-n*n;
            int y = 2*m*n;
            int z = m*m+n*n;
            if (z <= num)
            {
                sum++;
                vis[x] = 1;
                vis[y] = 1;
                vis[z] = 1;
                for (int j = 2; z*j <= num; j++)
                {
                    vis[j*x] = 1;
                    vis[j*y] = 1;
                    vis[j*z] = 1;
                }
            }
        }
    }
    for (int i = 1; i <= num; i++)
	{
		p[i] = p[i-1];
		if (!vis[i]) p[i]++;
	}
	printf("%d %d\n", sum, p[num]);
}

int main()
{
    int  n;
    while (~scanf("%d", &n))
	{
		query(n);
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值