A Bug‘s Life(权值并查集)

A Bug’s Life
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 53799 Accepted: 17292
Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
Hint
Huge input,scanf is recommended.
题意:给n只虫子,性别不同可以配对,找一找有没有同性配对的(有的话输出Suspicious bugs found!,否则,输出No suspicious bugs found!)

思路:利用带权值的并查集,假设虫子们的关系为1(异性),若通过题目信息计算出的结果不为1,找到homo虫子。

以下是源代码:

#include<cstdio>
using namespace std;

int const N = 2005;
int fa[N],ra[N];                          //左边是父集,右边是权值。

void init(int n){
    for(int i = 1;i <= n;i++){
        fa[i] = i;
        ra[i] = 0;
    }
}                        //初始化

int find(int x){
    int t,y,s = 0;
    int fx = x;
    while(fx != fa[fx]){
        s += ra[fx];
        fx = fa[fx];
    }                        //得到一个还没有%的S
    while(fa[x] != fx){
        t = fa[x];
        fa[x] = fx;
        y = ra[x];
        ra[x] = s % 2; 
        s -= y;
        x = t;
    }
    return fx;
}                        //压缩路径,得到ra[x]和fa[x]

bool merge(int x,int y,int r){
    int fx,fy;
    bool ret;
    
    fx = find(x);
    fy = find(y);
    ret = true;
    if(fx != fy){
        ra[fx] = (ra[x] + ra[y] + r) % 2;
        fa[fx] = fy;
    }else{
        ret = r == (ra[x] + ra[y]) % 2;
    }
    return ret;
}                                //判断计算关系与假设关系是否矛盾
int main(){
    int sec,x,y,a,b,num = 1;
    scanf("%d",&sec);
    for(int i = 1;i <= sec;i++){
        scanf("%d%d",&x,&y);
        init(x);
        bool homo = 0;
        for(int j = 1;j <= y;j++){
            scanf("%d%d",&a,&b);
            if(!merge(a,b,1)){
                homo = 1;
            }                        //结果为非假,即有 homo小虫        
        }
        printf("Scenario #%d:\n",num);
        if(homo){
            printf("Suspicious bugs found!\n",num++);
        }else{
            printf("No suspicious bugs found!\n",num++);
        }    
        printf("\n");
    }
    
    return 0;

tips:套用模板的题

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值