poj 1988 Cube Stacking

18 篇文章 0 订阅
Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 16031 Accepted: 5477
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2
 
注意合并时对根节点的处理。
AC代码:
#include <cstdio>
#include <cstring>

#define N 30005
using namespace std;

int father[N],up[N],num[N];   //up[i]为i上位的方块,num[i]为i所在堆的总方块数
int Find_set(int n)
{
    int temp;
    if(n==father[n]) return n;
    temp=father[n];
    father[n]=Find_set(father[n]);
    up[n]=up[n]+up[temp];            //更新n的偏移量,n的新偏移量等于n相对旧的根结点的偏移量+旧的根节点相对新的根节点的偏移量
    return father[n];
}

void Union(int a,int b)
{
    int ra=Find_set(a);
    int rb=Find_set(b);
    if(ra==rb) return;
    father[rb]=ra;                  //将ra所在堆放在rb所在堆上面
    up[rb]+=num[ra];                //rb上面的数目要加上ra所在堆的数目
    num[ra]+=num[rb];               //a所在堆的数目要加上rb所在堆的数目
}
int main()
{

    int p,a,b;
    char s[3];
    while(scanf("%d",&p)!=EOF)
    {
        for(int i=0; i<N; i++)
        {
            father[i]=i;
            num[i]=1;
            up[i]=0;
        }
        while(p--)
        {
            scanf("%s",s);
            if(s[0]=='M')
            {
                scanf("%d%d",&a,&b);
                Union(a,b);
            }
            else
            {
                scanf("%d",&a);
                int root=Find_set(a);
                printf("%d\n",num[root]-up[a]-1);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值