hdu 1671 Phone List

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6562    Accepted Submission(s): 2236


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
 

这道题就是判断一组字符串中是否有一个字符串是另一个字符串的前缀(字典树第二类应用)。

分析:我们只要在结点中添加一个nEndFlag成员变量即可。若nEndFlag == 1,说明该结点字符是某一字符串的结尾(假设为A),若在插入B字符串的过程中经过这一结点,则说明A是B的前缀;还有一种情况,当要插入最后一个字符c时,却发现p->next[c-'0']为真,则说明该字符串是一个前缀字符串,eg:先插入abcde,再插入abc这种情况

 
AC代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <cmath>
#include <string>
#define maxn 10
using namespace std;

typedef struct TireNode
{
    int nEndFlag;    标记该字符是否是某一字符串的结尾
    struct TireNode *next[maxn];
}TireNode;
TireNode Memory[1000000];
int allocp=0,nFlag=0;
/*初始化*/
void InitTireRoot(TireNode **pRoot)
{
    *pRoot=NULL;
}
/*创建新结点*/
TireNode *CreatTireNode()
{
    TireNode *p;
    p=&Memory[allocp++];
    p->nEndFlag=0;
    for(int i=0;i<maxn;i++)
    p->next[i]=NULL;
    return p;
}
/*插入*/
void InsertTire(TireNode **pRoot,char *s)
{
    int i=0,k;
    TireNode *p;
    if(!(p=*pRoot))
    p=*pRoot=CreatTireNode();
    while(s[i])
    {
        k=s[i++]-'0';         //确定branch
        if(p->next[k])
        {
            if(p->next[k]->nEndFlag==1||s[i]=='\0') //先短后长 || 先长后短
            {
                nFlag = 1;
                return;
            }
        }
        else
        p->next[k]=CreatTireNode();
        p=p->next[k];
    }
    p->nEndFlag=1;
}


int main()
{
    int t,n;
    char s[11];
    TireNode *Root;
    scanf("%d",&t);
    while(t--)
    {
    InitTireRoot(&Root);
    nFlag=allocp=0;
    scanf("%d",&n);
    getchar();
    while(n--)
    {
    gets(s);
    if(!nFlag)
    InsertTire(&Root,s);
    }
    if(!nFlag)
    printf("YES\n");
    else
    printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值