POJ 3368 解题报告 RMQ

Frequent values
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10935 Accepted: 4006

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

Source


题目大意:

给出一个连续不降的整数序列,序列长度为n (n<=1e6),接着给出q次询问,每次询问序列中从l到r中出现次数最多的数的个数。

解题思路:

利用RMQ我的如下,O(N)统计出每个数最右边和它相等的数的位置,记做rt[i]。
如样例中的      1 1 -1 -1 -1 -1 3 10 10 10
统计的rt数组是2 1 6   6  6   6 7  10 10 10
然后再计算出每个数到其最左边和它相等的数的长度
样例所得的数组c[i]为  1 2 1 2 3 4 1 1 2 3。

然后对于每次询问l r,答案就应该是l到其最右边的数的长度,和l最右边的下一个数到r中的c[i]的最大值。
比如对于询问2 4
a[l]的值为1,到其最右边的是i=2,长度为1,然后rt[l]+1=3到r=4中c最大的是2。所以答案就是2。
其中从rt[l]+1到r中求c[i]最大值可以用RMQ(也可以用线段树)来求。

代码供参考:
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int a[100100];
int rt[100100];
int dp[200100][30];
int log2(int x){
	int res=0;
	while(x){x/=2;res++;}
	return res;
}
int main(){
	int n,q;
	while(~scanf("%d",&n)){
		memset(dp,0,sizeof(dp));
		memset(rt,0,sizeof(rt));
		if(n==0)return 0;
		scanf("%d",&q);
		for(int i=1;i<=n;i++)scanf("%d",&a[i]);
		int now=n;
		rt[n]=n;
		for(int i=n-1;i>=1;i--){
			if(a[i]<a[now])now=i;
			rt[i]=now;
		}
		dp[1][0]=1;
		for(int i=2;i<=n;i++){
			if(a[i]==a[i-1])dp[i][0]=dp[i-1][0]+1;
			else dp[i][0]=1;
		}
		int log2n=log2(n)-1;
		for(int i=1;i<=log2n;i++){
			for(int j=1;j<=n;j++){
				dp[j][i]=max(dp[j][i-1],dp[j+(1<<(i-1))][i-1]);
			}
		}
		while(q--){
			int l,r;
			scanf("%d%d",&l,&r);
			if(rt[l]>=r)printf("%d\n",r-l+1);
			else{
				int tmp=rt[l]-l+1;
				int len=r-rt[l];
				int log2len=log2(len)-1;
				tmp=max(tmp,max(dp[rt[l]+1][log2len],dp[r-(1<<(log2len))+1][log2len]));
				printf("%d\n",tmp);
			}
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值