hdu4707 hdu1241-dfs&bfs

Hdu4707

Description

One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.
 

Input

The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.
 

Output

For each test case, outputin a single line the number of possible locations in the school the hamster may be found.
 

Sample Input

     
     
1 10 2 0 1 0 2 0 3 1 4 1 5 2 6 3 7 4 8 6 9
 

Sample Output

2

求出树中所有节点到原点距离大于D的点的个数

直接暴力很容易做

#include<iostream>
#include<cstdio>
#include<cstring>
int main()
{
    int T,N,D,d[100000];
    scanf("%d",&T);
    while(T--)
    {
        memset(d,0,sizeof(d));
        int a,b,cnt=0;
        scanf("%d%d",&N,&D);
        for(int i=1;i<N;i++)
        {
            scanf("%d%d",&a,&b);
            d[b]=d[a]+1;
            if(d[b]>D)
                cnt++;
        }
        printf("%d\n",cnt);
    }
    return 0;
}

————————————————————————————————————————————————————————————————————————————————————————————————————

——————————————————                     分割线                           ————————————————

————————————————————————————————————————————————————————————————————————————————————————————————————

Hdu1241

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input

      
      
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output

      
      
0 1 2 2


(1)dfs

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int m,n;
char p[105][105];
bool vis[105][105];
void dfs(int x,int y)
{
    int x2,y2;
    vis[x][y]=false;//printf("%d %d %d\n",x,y,vis[x][y]);
    for(int x1=-1;x1<=1;x1++)
    {
        for(int y1=-1;y1<=1;y1++)
        {
            x2=x+x1;y2=y+y1;
            if(vis[x2][y2]&&x2>=0&&x2<m&&y2>=0&&y2<n&&p[x2][y2]=='@')
                dfs(x2,y2);
        }
    }
}
int main()
{
    while(~scanf("%d%d",&m,&n)&&m!=0&&n!=0)
    {
        int i,j,cnt=0,num=0;
        memset(vis,true,sizeof(vis));
        memset(p,0,sizeof(p));
        for(i=0;i<m;i++)
            scanf("%s",p[i]);
        for(i=0;i<m;i++)
            for(j=0;j<n;j++)
        {
            if(vis[i][j]&&p[i][j]=='@')
            {
                dfs(i,j);
                cnt++;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}

(2)bfs

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct Node
{
    int x;
    int y;
};
int m,n;
int dir[8][2]={{1,0},{-1,0},{0,1},{0,-1},{1,1},{-1,1},{1,-1},{-1,-1}};
bool vis[105][105];
char p[105][105];
void bfs(int x,int y)
{
    queue<Node> q;
    Node node;
    vis[x][y]=false;
    node.x=x;
    node.y=y;
    q.push(node);
    while(!q.empty())
    {
        Node cur=q.front();
        Node next;
        q.pop();
        for(int i=0;i<8;i++)
        {
            next.x=cur.x+dir[i][0];
            next.y=cur.y+dir[i][1];
            if(p[next.x][next.y]=='@'&&vis[next.x][next.y]&&next.x>=0&&next.x<m&&next.y>=0&&next.y<n)
            {
                vis[next.x][next.y]=false;
                q.push(next);
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d",&m,&n)&&m!=0&&n!=0)
    {
        memset(vis,true,sizeof(vis));
        memset(p,0,sizeof(p));
        int cnt=0;
        for(int i=0;i<m;i++)
        {
            scanf("%s",p[i]);
        }
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
        {
            if(vis[i][j]&&p[i][j]=='@')
            {
                cnt++;
                bfs(i,j);
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值