7-2 浪漫侧影

7-2 浪漫侧影

分数 50

全屏浏览

切换布局

作者 陈越

单位 浙江大学

v.JPG

“侧影”就是从左侧或者右侧去观察物体所看到的内容。例如上图中男生的侧影是从他右侧看过去的样子,叫“右视图”;女生的侧影是从她左侧看过去的样子,叫“左视图”。

520 这个日子还在打比赛的你,也就抱着一棵二叉树左看看右看看了……

我们将二叉树的“侧影”定义为从一侧能看到的所有结点从上到下形成的序列。例如下图这棵二叉树,其右视图就是 { 1, 2, 3, 4, 5 },左视图就是 { 1, 6, 7, 8, 5 }。

fig.JPG

于是让我们首先通过一棵二叉树的中序遍历序列和后序遍历序列构建出一棵树,然后你要输出这棵树的左视图和右视图。

输入格式:

输入第一行给出一个正整数 N (≤20),为树中的结点个数。随后在两行中先后给出树的中序遍历和后序遍历序列。树中所有键值都不相同,其数值大小无关紧要,都不超过 int 的范围。

输出格式:

第一行输出右视图,第二行输出左视图,格式如样例所示。

输入样例:

8
6 8 7 4 5 1 3 2
8 5 4 7 6 3 2 1

输出样例:

R: 1 2 3 4 5
L: 1 6 7 8 5

感谢用户DSA修正数据!

import sys
from collections import deque

input = sys.stdin.readline

class TreeNode:
    def __init__(self, val):
        self.val = val
        self.lchild = None
        self.rchild = None

def create(midd, post):
    if not midd or not post:
        return None
    val = post[-1]
    idx = midd.index(val)
    root = TreeNode(val)
    root.lchild = create(midd[:idx], post[:idx])
    root.rchild = create(midd[idx + 1:], post[idx:-1])
    # root.rchild = create(midd[idx + 1:], post[idx:len(post) - 1])
    return root

def bfs(root):
    if not root:
        return []
    q = deque()
    q.append(root)
    L = []
    R = []
    while q:
        temp = []
        lenn = len(q)
        for _ in range(lenn):
            node = q.popleft()
            temp.append(node.val)
            if node.lchild:
                q.append(node.lchild)
            if node.rchild:
                q.append(node.rchild)
        L.append(temp[0])
        R.append(temp[-1])
    print("R: " + ' '.join(map(str, R)))
    print("L: " + ' '.join(map(str, L)))

n = int(input().strip())
middle = list(map(int, input().strip().split()))
post = list(map(int, input().strip().split()))
root = create(middle, post)
bfs(root)
  • 2
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值