Kattis - Tractor

Bessie the Cow has stolen Farmer John’s tractor and is running wild on the coordinate plane! She, however, is a terrible driver, and can only move according to the following rules:

  1. Each of her movements is in the same direction as either the positive xx-axis or the positive yy-axis.

  2. Her nnth movement takes her 2n12n−1 units forward in her chosen direction. (On her first movement, n=1n=1, so she moves 11 unit.)

Farmer John’s farm is on the coordinate plane, in the shape of a rectangle with corners at (0,0)(0,0)(A,0)(A,0)(0,B)(0,B) and (A,B)(A,B). If Bessie starts at (0,0)(0,0), how many points inside the farm, including the boundary, could she reach?

Input

The input begins with an integer NN (1N1001≤N≤100) on a line by itself, indicating the number of test cases that follow. Each of the following NN lines contains two space separated integers AA and BB (1A,B1081≤A,B≤108), describing the upper-right corner of Farmer John’s farm.

Output

Output NN lines, with the NNth line containing the number of points that Bessie could possibly reach in the NNth test case.

In the first test case of the sample, Bessie can reach the following six points: (0,0)(0,0)(0,1)(0,1)(1,0)(1,0)(1,2)(1,2)(2,1)(2,1) and (3,0)(3,0).

Sample Input 1Sample Output 1
2
2 3
7 7
6
15
一开始没看到数据大小是10^8,用bfs做结果超时了……后来想了一下大概是个数学问题

#include <iostream>
#include <string>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <stack>
#include <set>
#include <queue>
#include <map>
#include <algorithm>
using namespace std;
int t, a, b;
int main() {
    cin >> t;
    while (t--) {
        cin >> a >> b;
        int ans = 0;
        for (int i = 1; ; i = i * 2 + 1) {
            int y1 = max(0, i - b), y2 = min(a, i);
            if (y1 > a) break;
            ans += abs(y1 - y2) + 1;
        }
        cout << ans + 1 << endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值