Ignatius and the Princess I(HDOJ-1026)

Problem Description

The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166’s castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166’s room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

Input

The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

Output

For each test case, you should output “God please help our poor hero.” if Ignatius can’t reach the target position, or you should output “It takes n seconds to reach the target position, let me show you the way.”(n is the minimum seconds), and tell our hero the whole path. Output a line contains “FINISH” after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.

Sample Input

5 6
.XX.1.
..X.2.
2…X.
…XX.
XXXXX.
5 6
.XX.1.
..X.2.
2…X.
…XX.
XXXXX1
5 6
.XX…
..XX1.
2…X.
…XX.
XXXXX.

Sample Output

It takes 13 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
FINISH
It takes 14 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
14s:FIGHT AT (4,5)
FINISH
God please help our poor hero.
FINISH

一道很好的BFS题目,我也很喜欢这种有路径输出的题目,会有种像是在玩游戏的感觉,很爽。

题意:

题目不难理解,就是从(0,0)走到(n-1,m-1)的最短距离,中途有数字,代表需要战斗的时间。

思路:

由于战斗需要额外的时间,而这样为了实现最短路径可以就采用贪心的思想,用一个优先队列替换原先bfs的队列,使得当前最短的边永远在队列的最顶端进行下一次搜索。
在path里标记前一次路径的坐标与时间,递归进行输出。

wa了一次……无法走到时也是要输出FINISH的,没有注意到……

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <iterator>
#include <sstream>
#include <fstream>
#include <list>
#define MST(a,b) memset(a,(b),sizeof(a));
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int INF = 0x3f3f3f3f;
const int MAXN = 100 + 20;
char maze[MAXN][MAXN];
bool vis[MAXN][MAXN];
int n, m, res;
int dir[4][2] = {{1, 0}, {0, 1}, {-1, 0}, {0, -1}};
struct path {
    int pre_x, pre_y, time;
    path(int _x, int _y, int _t) {
        pre_x = _x;
        pre_y = _y;
        time = _t;
    }
    path() {}
} p[MAXN][MAXN];
struct node {
    int x, y, cnt;
    bool operator < (const node &a) const {
        return cnt > a.cnt;
    }
    node(int _x, int _y, int _c) {
        x = _x;
        y = _y;
        cnt = _c;
    }
    node() {}
} S;
void init() {
    MST(p, 0);
    MST(maze, 0);
    res = INF;
}
void bfs(node s) {
    priority_queue <node> q;
    q.push(s);
    node now, next;
    MST(vis, false);
    vis[s.x][s.y] = true;
    p[s.x][s.y] = {0, 0, 0};
    while (!q.empty()) {
        now = q.top();
        q.pop();
//        cout << now.x << " " << now.y << " " << now.cnt << endl;
        if (now.x == n - 1 && now.y == m - 1) {
//            cout << now.x << " " << now.y << " " << now.cnt << endl;
            res = min(now.cnt, res);
            return ;
        }
        for (int i = 0; i < 4; i++) {
            next.x = now.x + dir[i][1];
            next.y = now.y + dir[i][0];
            next.cnt = now.cnt + 1;
            if (next.x < 0 || next.y < 0 || next.x >= n || next.y >= m) continue;
            if (vis[next.x][next.y] || maze[next.x][next.y] == 'X') continue;
            if (maze[next.x][next.y] >= '1' && maze[next.x][next.y] <= '9')
                next.cnt += (maze[next.x][next.y] - '0');
            vis[next.x][next.y] = true;
            q.push(next);
            p[next.x][next.y] = {now.x, now.y, now.cnt};
        }
    }
}
void print_path(int x, int y) {
    if (p[x][y].pre_x + p[x][y].pre_y) print_path(p[x][y].pre_x, p[x][y].pre_y);
    printf("%ds:(%d,%d)->(%d,%d)\n", p[x][y].time, p[x][y].pre_x, p[x][y].pre_y, x, y);
    if (maze[x][y] >= '1' && maze[x][y] <= '9') {
        for (int i = p[x][y].time + 1; i <= p[x][y].time + maze[x][y] - '0'; i++)
            printf("%ds:FIGHT AT (%d,%d)\n", i, x, y);
    }
}
int main() {
    while (scanf("%d %d", &n, &m) != EOF) {
        getchar();
        init();
        for (int i = 0; i < n; i++) {
            for (int j = 0; j < m; j++)
                scanf("%c", &maze[i][j]);
            getchar();
        }
        bfs({0, 0, 1});
        if (res == INF) printf("God please help our poor hero.\n");
        else {
            printf("It takes %d seconds to reach the target position, let me show you the way.\n", res - 1);
//            for (int i = 0; i < n; i++)
//                for (int j = 0; j < m; j++) {
//                    printf("%d,%d,%d", p[i][j].pre_x, p[i][j].pre_y, p[i][j].time);
//                    if (j == m - 1) printf("\n");
//                    else printf("  ");
//                }
            print_path(n - 1, m - 1);
        }
        printf("FINISH\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值