HDU 1026 Ignatius and the Princess I (搜索-广度优先搜索)

Ignatius and the Princess I

Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
 

Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
 

Output
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
 

Sample Input
 
  
5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.
 

Sample Output
 
  
It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1072  1175  1180  1016  1253 
 


题目大意:

给定1张图,走到“.”需要1步,走到数字除了需要1步,还要停留数字上那么多步,“#”不能走,问你从左上角到右下至少走多少步,并输出路径


解题思路:

简单的BFS,再加上记录前1步可以从终点往前来获得路径。


解题代码:

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;

struct node{
    int x,y,step;
    node(int x0=0,int y0=0,int step0=0){
        x=x0;y=y0;step=step0;
    }
};

const int offx[]={1,-1,0,0};
const int offy[]={0,0,-1,1};
int n,m,step[110][110],pre[110][110];
char a[110][110];

void solve(){
    memset(step,-1,sizeof(step));
    memset(pre,-1,sizeof(pre));
    queue <node> q;
    q.push(node(0,0,0));
    step[0][0]=0;
    while(!q.empty()){
        node s=q.front();
        q.pop();
        for(int i=0;i<4;i++){
            int dx=s.x+offx[i],dy=s.y+offy[i],newstep;
            if(dx<0 || dx>=n || dy<0 || dy>=m) continue;
            if(a[dx][dy]=='X') continue;
            if(a[dx][dy]=='.') newstep=s.step+1;
            else newstep=s.step+1+a[dx][dy]-'0';
            if(newstep<step[dx][dy] || step[dx][dy]==-1){
                step[dx][dy]=newstep;
                pre[dx][dy]=i;
                q.push(node(dx,dy,step[dx][dy]));
            }
        }
    }
}

void dfs(int dx,int dy){
    if(pre[dx][dy]==-1) return;
    int sx=dx-offx[pre[dx][dy]],sy=dy-offy[pre[dx][dy]];
    dfs(sx,sy);
    printf("%ds:(%d,%d)->(%d,%d)\n",step[sx][sy]+1,sx,sy,dx,dy);
    if(a[dx][dy]!='.'){
        for(int i=1;i<=a[dx][dy]-'0';i++){
            printf("%ds:FIGHT AT (%d,%d)\n",step[sx][sy]+1+i,dx,dy);
        }
    }
}

void output(){
    if(step[n-1][m-1]==-1){
        printf("God please help our poor hero.\n");
    }else{
        printf("It takes %d seconds to reach the target position, let me show you the way.\n",step[n-1][m-1]);
        dfs(n-1,m-1);
    }
    printf("FINISH\n");
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        for(int i=0;i<n;i++) scanf("%s",a[i]);
        solve();
        output();
    }
    return 0;
}


转载于:https://www.cnblogs.com/toyking/p/3893184.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值