[PAT乙级]1010. 一元多项式求导 (25)

1010. 一元多项式求导 (25)

原题链接

设计函数求一元多项式的导数。(注:xn(n为整数)的一阶导数为n*xn-1。)

输入格式:以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。注意“零多项式”的指数和系数都是0,但是表示为“0 0”。

输入样例:
3 4 -5 2 6 1 -2 0
输出样例:
12 3 -10 1 6 0

注意:

  • 如果没有输入就是零多项式,这时候要输出“0 0”
  • 指数为0时没有输出,输出样例中的0对应输入样例的1

代码:

#include <cstdio>
using namespace std;

int main()
{
    int a,b;
    bool isfirst = true;
    while(~scanf("%d %d", &a, &b)){
        if(b == 0)//指数为0时没有输出
            continue;
        if(!isfirst)
            printf(" ");
        else
            isfirst = false;
        printf("%d %d", a*b, b-1);
    }
    if(isfirst)//没有输入,即零多项式
        printf("0 0");
    return 0;
}
  • 以下是错误代码,慎看
  • 做这道题时我以为是要考察字符串处理,结果,写了以下一堆代码,去测试没有通过,但是我没有看出来错在哪儿。。。。还是贴一下代码吧,虽然很复杂、。。
#include <iostream>
#include <string>
#include <vector>
using namespace std;

int main()
{
    string s;
    getline(cin, s);
    if(s == ""){
        cout << "0 0";
        return 0;
    }
    vector<string> arr;
    int k=0;//数字的第一个下标
    bool flag = true;
    for(int i=0; i<s.size(); i++){//字符串分割,分成一个个字符串表示的数字
        if(s[i] == ' '){
            string temp = s.substr(k, i-k);
            arr.push_back(temp);
            k = i + 1;//下一个数字的第一个下标
        }
    }
    arr.push_back(s.substr(k, s.size()-k));//将最后一个字符串表示的数字加入数组
    vector<int> res(arr.size());//存储输入的所有数字
    for(int i=0; i<arr.size(); i++){
        if(arr[i][0] == '-'){
            int temp=0;
            for(int j=1; j<arr[i].size(); j++)
                temp = (arr[i][j]-'0') + temp*10;
            res[i] = -temp;
        }else{
            int temp=0;
            for(int j=0; j<arr[i].size(); j++)
                temp = (arr[i][j]-'0') + temp*10;
            res[i] = temp;
        }
    }
    vector<int> test;//存储要输出的数字
    for(int i=0; i<res.size(); i+=2){
        if(res[i+1]==0){
            continue;
        }
        test.push_back(res[i]*res[i+1]);
        test.push_back(res[i+1]-1);

    }
    for(int i=0; i<test.size(); i++){
        if(i != 0)
            cout << " ";
        cout << test[i];
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值