python编译出错:Could not build the ssl module! Python requires an OpenSSL 1.0.1

python爬虫系列 专栏收录该内容
2 篇文章 0 订阅

原文链接:https://blog.csdn.net/devalone/article/details/82459276

在编译python3.7的时候有一个错误,这个错误是ssl模块不能编译,版本不对,虽然说python仍然能使用,但是不能使用https协议,这对于如今的网络环境肯定是不行的,下面介绍博主是如何解决这个问题的。
下载libressl ,代替openssl,下载地址:https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.7.4.tar.gz

编译安装:
cd libressl-2.7.4
./configure --prefix=/usr/local
sudo make install

新建或修改 /etc/ld.so.conf.d/local.conf 配置文件,添加如下内容:

/usr/local/lib

即将 /usr/local/lib 目录加入到模块加载目录。
重新加载共享模块:

sudo ldconfig -v

重新编译python:
回到 Python目录,编辑安装文件 Modules/Setup
删除有关 ssl 编译代码的注释,共 4 行

SSL=/usr/local
_ssl _ssl.c \
        -DUSE_SSL -I$(SSL)/include -I$(SSL)/include/openssl \
        -L$(SSL)/lib -lssl -lcrypto

这样重新编译python之后,就可以正常导入ssl模块了

  • 0
    点赞
  • 0
    评论
  • 6
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值