1046 Shortest Distance (20 分)(贪心算法)

1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D​1 D2 ⋯ DN​​ , where D​i is the distance between the i-th and the (i+1)-st exits, and D​N is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107​ .

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
分析

若采取常规方法,测试点2(starting from 0)会超时,此处采用空间换时间降低时间复杂度 ,具体做法是:在输入的同时计算每个点到第一个点的距离,并将它存放在数组dis中。两点的距离要么环的劣弧,要么是环的优弧,这里先固定一下即求由a到b的距离(a<b),另一端距离用总round trip distance(圆环总长度)减去这里求的距离,比较两者取最小值,特别地,总距离程序中用虚拟的第n+1点表示,因为它到第一个点的距离恰好等于圆环长度。
圆环总长度小于107,那么距离值可以定义为int.

#include<iostream> 
using namespace std;
int dis[100010];
int main(){
	int n,m;
	scanf("%d",&n);
	for(int i=1;i<=n;i++) {
		int tmpdis;
		scanf("%d",&tmpdis);
		if(i==1) dis[i+1]=tmpdis;
		else dis[i+1]=dis[i]+tmpdis;
	}
	scanf("%d",&m);
	for(int i=0;i<m;i++){
		int a,b;
		cin>>a>>b;
		if(a>b) swap(a,b);
		int tmpsum=dis[b]-dis[a];
		cout<<min(tmpsum,dis[n+1]-tmpsum)<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值