1025 PAT Ranking (25 分)(排序)

1025 PAT Ranking (25 分)(排序)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
题目大意

PAT考试分多个考场同时进行,系统需要我们设计在给定每个分考场的考生ID和分数后,输出他们在他所在考场的排名和在此次PAT的排名。

分析

先在本小组进行排名,然后修改小组排名信息,然后再对整场考试考生进行排名,然后修改总排名。

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct node {
    string id;
    int num,score,localrank,rank;
};
bool cmp(node a,node b) {
    return a.score!=b.score?a.score>b.score:a.id<b.id;
}
int main() {
    int n,num=1;
    cin>>n;
    vector<node> ans;
    for(int k=0; k<n; k++) {
        int cnt;
        cin>>cnt;
        vector<node> tmp;
        for(int j=0; j<cnt; j++) {
            node nd;
            cin>>nd.id>>nd.score;
            nd.num=num;
            tmp.push_back(nd);
        }
        sort(tmp.begin(),tmp.end(),cmp);
        int localnum=2;
        tmp[0].localrank=1;
        ans.push_back(tmp[0]);
        for(int i=1; i<cnt; i++) {
            if(tmp[i].score==tmp[i-1].score) tmp[i].localrank=tmp[i-1].localrank;
            else tmp[i].localrank=localnum;
            localnum++;
            ans.push_back(tmp[i]);
        }
        num++;
    }
    sort(ans.begin(),ans.end(),cmp);
    int totalnum=2;
    ans[0].rank=1;
    for(int k=1; k<(int)ans.size(); k++) {
        if(ans[k].score==ans[k-1].score) ans[k].rank=ans[k-1].rank;
        else ans[k].rank=totalnum;
        totalnum++;
    }
    cout<<ans.size()<<endl;
    for(auto it : ans) {
        cout<<it.id<<" "<<it.rank<<" "<<it.num<<" "<<it.localrank<<endl;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值