1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

计算一下当地排名,存储为个人属性,再汇总排序,注意这种排序方法,在乙级和甲级都频繁的见到,相同分数排名相同,但是总的排名还是随着人数增加而增加,一旦分数不同了,恢复为人数的排名,然后后面的人分数再跟这个人分数比较。跟PAT的排名方式是一样的。

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
struct node
{
	string registration_number;
	int location_number;
	int score;
	int local_rank;
};
bool rule(const node& a, const node& b)
{
	return a.score != b.score? a.score > b.score:a.registration_number < b.registration_number;
}
int main()
{
	int n,a,grade;
	string str;
	cin >> n;
	vector<node>* re=new vector<node>[n];
	vector<node>solution;
	for (int i = 0; i < n; i++)
	{
		cin >> a;
		for (int j = 0; j < a; j++)
		{
			cin >> str >> grade;
			re[i].push_back(node{ str,i + 1,grade });
		}
	}
	for (int i = 0; i < n; i++)
	{
		sort(re[i].begin(), re[i].end(), rule);
		int m = 1, lastscore = re[i][0].score;
		for (int j = 0; j < re[i].size(); j++)
		{
			if(re[i][j].score==lastscore)
				re[i][j].local_rank = m;
			else
			{
				re[i][j].local_rank = j + 1;
				m = j + 1;
				lastscore = re[i][j].score;
			}
			solution.push_back(re[i][j]);
		}
	}
	sort(solution.begin(), solution.end(),rule);
	cout << solution.size()<<endl;
	int rank = 1,lastgrade=solution[0].score;
	for (int i = 0; i < solution.size(); i++)
		if (solution[i].score == lastgrade)
			cout << solution[i].registration_number << " " << rank << " " << solution[i].location_number <<" "<< solution[i].local_rank << endl;
		else
		{
			lastgrade = solution[i].score;
			rank = i + 1;
			cout << solution[i].registration_number << " " << rank << " " << solution[i].location_number <<" "<< solution[i].local_rank << endl;
		}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值