POJ3259-Wormholes(SPFA 判负环)

                    Wormholes
   Time Limit: 2000MS       Memory Limit: 65536K

Description
   While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
   As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
   To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
   Line 1: A single integer, F. F farm descriptions follow. 
   Line 1 of each farm: Three space-separated integers respectively: N, M, and W 
   Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
   Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output
   Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

-

Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题解

英文题目我就不翻译了,都是学霸。

题目大意:有一张图,包含负权,判断有无负环。

直接跑SPFA判负环。

代码

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
const int MAXM=25000+10;
const int MAXN=5000+10;
struct edge{int to,next,v;}e[MAXM*2];
int n,m,x,head[MAXN],cnt,dis[MAXN],num[MAXN];
bool vis[MAXN];
inline void add(int u,int v,int w)
{
    cnt++;
    e[cnt].to=v;
    e[cnt].v=w;
    e[cnt].next=head[u];
    head[u]=cnt;
}
bool spfa(int s)
{
    memset(dis,0x3f,sizeof(dis));
    memset(vis,0,sizeof(vis));
    memset(num,0,sizeof(num));
    queue<int>q;
    while(!q.empty()) q.pop();
    dis[s]=0;
    vis[s]=true;
    num[s]=1;
    q.push(s);
    while(!q.empty())
    {
        int t=q.front();
        q.pop();
        vis[t]=false;
        for(int i=head[t];i;i=e[i].next)
        {
            int temp=e[i].to;
            if(dis[temp]>dis[t]+e[i].v)
            {
                dis[temp]=dis[t]+e[i].v;
                if(!vis[temp])
                {
                    num[temp]++;
                    if(num[temp]>=n) return true;
                    vis[temp]=true;
                    q.push(temp);
                }
            }
        }
    }
    return false;
}
int main()
{
    int _;
    scanf("%d",&_);
    while(_--)
    {
        cnt=0;
        memset(head,0,sizeof(head));
        scanf("%d%d%d",&n,&m,&x);
        for(int i=1;i<=m;i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,w);add(v,u,w);
        }
        for(int i=1;i<=x;i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,w*-1);
        }
        bool flag=false;
        for(int i=1;i<=n;i++)
        {
            if(spfa(i))
            {
                flag=true;
                break;
            }
        }
        if(flag) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值