(解题报告)HDU1020---Encoding

Encoding
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

  1. Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.
  2. If the length of the sub-string is 1, ‘1’ should be ignored.

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.

Output
For each test case, output the encoded string in a line.

Sample Input
2
ABC
ABBCCC

Sample Output
ABC
A2B3C

这个题有一个挺坑的误区,不是统计字符串中出现的所有字符的个数,而是统计相邻的个数!
strlen()表示字符数组的长度。
使用num进行计数。

#include <stdio.h>
#include <string.h>
int main(){
    int n,i,num;
    char str[10001];
    scanf("%d",&n);
    while(n--){
        num=1;
        scanf("%s",str);
      for(i=0;i<strlen(str);i++){
          if(str[i]==str[i+1]){ //如果一个字符跟它后面的字符相同则num++;
                          num++;
          }
          else{
              if(num<=1) {
                     printf("%c",str[i]);
                     num=1;
                     }//记住num要重置为1。
              else{
                       printf("%d%c",num,str[i]);
                       num=1; 
                  }
          }
      }printf("\n");
    }return 0;
}
  • 5
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值