Bomb HDU - 3555 数位DP

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.
The input terminates by end of file marker.

Output
For each test case, output an integer indicating the final points of the power.

Sample Input
3
1
50
500

Sample Output
0
1
15

Hint

From 1 to 500, the numbers that include the sub-sequence “49” are “49”,“149”,“249”,“349”,“449”,“490”,“491”,“492”,“493”,“494”,“495”,“496”,“497”,“498”,“499”,
so the answer is 15.

题意:给定一个区间[1,r],求该区间内包含49的数的个数

我们考虑有一共几种状态,一个数可分为带49的数和不带49的数,而对于不带49的数,开头是9和开头不是9计数是不同的,因此我们可以建立一个二维数组dp[n][3],dp[i][0]表示i位数中不带49的数的个数,dp[i][1]表示i位数中不带49,但是最高位是9的数的个数,dp[i][2]表示i位数中带49的数的个数

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
int dit[50];
ll dp[50][3],n,m;
ll dfs(int pos,int st,int limit)
{
	if(pos<0) return st==2;
	if(!limit&&dp[pos][st]!=-1) return dp[pos][st];
	int up=limit?dit[pos]:9;
	ll ans=0;
	for(int i=0;i<=up;i++)
	{
		if(st==2||st==1&&i==9)
			ans+=dfs(pos-1,2,limit&&i==dit[pos]);
		else if(i==4)
			ans+=dfs(pos-1,1,limit&&i==dit[pos]);
		else
			ans+=dfs(pos-1,0,limit&&i==dit[pos]);
	}
	if(!limit) dp[pos][st]=ans;
	return ans;
}
ll solve(ll x)
{
	int len=0;
	while(x)
	{
		dit[len++]=x%10;
		x/=10;
	}
	return dfs(len-1,0,1);
}
int main()
{
	int t;
	cin>>t;
	memset(dp,-1,sizeof(dp));
	while(t--)
	{
		cin>>n;
		cout<<solve(n)<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值