HDU1597 find the nth digit

Problem Description
假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
.........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
............
S18 = 123456789123456789
..................
现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912.........
那么你能告诉我在S串中的第N个数字是多少吗?
 

Input
输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。
 

Output
对于每个N,输出S中第N个对应的数字.
 

Sample Input
  
  
6 1 2 3 4 5 10
 

Sample Output
  
  
1 1 2 1 2 4
//由i*(i+1)/2=n,可以求出 i,然后由i%9,就可得出答案 
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
	double n;	
	__int64 i,j,T,y;
	scanf("%I64d",&T);
	while(T--)
	{
		scanf("%lf",&n);
		double x=sqrt(2*n*1.0+0.25)-0.5;//i*(i+1)/2=n -> (i*i+i+0.25)=2*n-0.25 -> (i+0.5)^2=(2*n-0.25)
		if(x>(int)x/1) y=(int)x/1+1;
		else y=(int)x/1;  //向上取整,因为要满足i*(i-1)/2<n<i*(i+1)/2,n就处于sum(i-1)--sum(i)之间,然后求余
		int sum=y*(y-1)/2;
	 	y=n-sum;
		if(y%9==0)
		cout<<"9";
		else cout<<y%9;
		cout<<endl;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值