POJ 1852 Ants

 
Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10322 Accepted: 4578

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source



解题思路:
水题一道,感觉就是枚举加贪心,n最大才10^6,所以直接枚举就行了,把相互碰面的两个蚂蚁就当成是“穿身了”,也就是说,不考虑掉头问题,把相遇前的运动和相遇后的运动的主体当做是同一个蚂蚁。

哎,这个月的最后一道题了,进入考试周了,课本上好多东西都没学,滚粗了,寒假见了~

代码:
# include<cstdio>
# include<iostream>
# include<algorithm>

using namespace std;

# define MAX 1234567

int a[MAX];

int main(void)
{
    int t;cin>>t;

    while ( t-- )
        {
            int L;cin>>L;
            int n;cin>>n;

            for ( int i = 0;i < n;i++ )
                {
                    cin>>a[i];
                }
            int maxn = 0;
            for ( int i = 0;i < n;i++ )
                {
                    maxn = max( maxn, max(a[i],L-a[i]));
                }

            int minn = 0;
            for ( int i = 0;i < n;i++ )
                {
                    minn = max( minn,min(a[i],L-a[i]) );
                }

                cout<<minn<<" "<<maxn<<endl;
        }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值