挑战2.1 Smallest Difference

E - Smallest Difference
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0. 

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.

Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.

Sample Input

1
0 1 2 4 6 7

Sample Output

28

题目大意:
给你一串数字,然后将这串数字构成两个数字,使得这两个数字的差的绝对值最小。


解题思路:

这道题以前做过,当时是参考的网上的题解写了两个dfs暴力匹配出了两个数字,使得这两个数字的差的绝对值最小。这次改了写法,因为,我们知道,对于一串数字来说,

要使他们构成的数字的差的绝对值最小,那么位数肯定是一个决定性的因素,所以我们让aa的长度为n/2,那么bb的长度就是n-n/2了。那么,这样一来,只需要开始构造出aa的值,然后再step达到n/2的时候,开始构造bb,这样就能得到我们所得到的结果了,在处理的过程中,千万不要忘记处理前导0,程序中用到了next_permutation函数来生成有关bb的所有种组合。

代码:

# include<cstdio>
# include<iostream>
# include<algorithm>
# include<cstring>
# include<string>
# include<cmath>
# include<queue>
# include<stack>
# include<set>
# include<map>

using namespace std;

# define inf 999999999

int a[23];
int b[23];
int book[23];
int n,ans;

void solve( int aa )
{
    int len = 0;
    int bb = 0;
    for ( int i = 0;i < n;i++ )
    {
        if ( book[i] == 0 )
        {
            b[len++] = a[i];
            bb = bb*10+a[i];
        }
    }
    if ( b[0]!=0||len==1 )
    {
        ans = min(ans,abs(aa-bb));
    }
    while ( next_permutation(b,b+len))
    {
        bb = 0;
        for ( int i = 0;i < len;i++ )
        {
            bb = bb*10+b[i];
        }
        if ( b[0]!=0||len==1 )
        {
            ans = min(ans,abs(aa-bb));
        }
    }
}


void dfs( int step,int res )
{
    if ( step==n/2 )
    {
        solve( res );
        return;
    }

    for ( int i = 0;i < n;i++ )
    {
        if ( book[i]==0 )
        {
            if ( a[i]==0&&step==0 )
                continue;
            book[i] = true;
            dfs ( step+1,res*10+a[i] );
            book[i] = false;
        }
    }
}

int main(void)
{
    int t;cin>>t;
    getchar();
    while ( t-- )
    {
        n = 0;
        char ch;
        while ( (ch=getchar())!='\n' )
        {
            if ( ch==' ' )
                continue;
            a[n++] = ch - '0';
        }
        ans = inf;
        memset(book,false,sizeof(book));
        dfs(0,0);
        cout<<ans<<endl;
    }

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值