20140709 【高精度浮点数】POJ 1001 Exponentiation

5 篇文章 0 订阅
4 篇文章 0 订阅

Online JudgeProblem SetAuthorsOnline ContestsUser
Web Board
Home Page
F.A.Qs
Statistical Charts
Problems
Submit Problem
Online Status
Prob.ID:
Register
Update your info
Authors ranklist
Current Contest
Past Contests
Scheduled Contests
Award Contest
wilson1068      Log Out
Mail:0(0)
Login Log      Archive
北京大学暑期课:《ACM/ICPC竞赛训练》面向全球招生
Language:
Exponentiation
Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 133236 Accepted: 32560

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input: 
s is a string and  n is an integer 
C++

while(cin>>s>>n)

{

...

}

c

while(scanf("%s%d",s,&n)==2) //to  see if the scanf read in as many items as you want

/*while(scanf(%s%d",s,&n)!=EOF) //this also work    */

{

...

}

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator


一道高精度的题目, 使用 JAVA 是最好的选择(在JAVA不超时,不爆内存的情况下)。
【虽然用JAVA来写很慢,内存占用也大,但是丰富的JAVA库可以使你的代码很短。这就是牺牲“时间空间”换取代码的简洁】
写这个主要是记录一些A题上常用的JAVA方法。
Scanner 专为编程比赛而设的IO类[ 包含在 java.util.* 中 ]
使用 nextBigInteger() 读入一个高精度整数
使用 nextBigDecimal() 读入一个高精度浮点数
使用 nextInt() 读入一个整数(传统方式......)//类似于 scanf("%d", &a);
使用 hasNext() 判断是否还有数据未读//类似于 EOF != scanf("%d", &n);

使用 next() 读入行字符串//类似于 scanf("%s", s);

BigInteger 高精度整数类, 可以建立高精度整数对象.(方法二者类似, 具体情况请查看API文档)

BigDecimal 高精度浮点数类, 可以建立高精度浮点数对象.[ 包含在 java.math.* 中 ]

BigDecimal.valueOf(108000.112)方法把一个数据(double型等)转成高精度浮点数

BigDecimal.doubleValue()把高精度浮点数转换成 double 型

BigDecimal.stripTrailingZeros()去掉后面多余的0(BigDecimal类比较坑的地方, 不会主动去掉后面多余的0)

BigDecimal.toPlainString()把高精度浮点数转变成字符串(完全展开的, 直接使用toString()方法可能得到的字符串是包含E的科学计数的数值)

BigDecimal.pow(n)计算高精度数的幂(只能是整数倍)

BigDecimal.multiply(BigDecimal)两个高度精度数相乘



String 字符串(不可更改的)

String.startWith(startString)判断字符串是否以 startString 开头

String.subString(start, end)输出字符串的 [ start, end ) 位置的子串.


详情请看JAVA的API文档:

Java™ Platform, Standard Edition 7            API Specification



import java.util.*;
import java.math.*;

public class Main {
	public static void main(String[] args) throws Exception{
		Scanner sc = new Scanner(System.in);
		while( sc.hasNext() ){
			BigDecimal c = sc.nextBigDecimal();
			int n = sc.nextInt();
			BigDecimal ans = BigDecimal.valueOf(1.0);
			//ans.pow(n);
			for(int i=0; i<n; i++)		ans = ans.multiply(c);
			String s = ans.stripTrailingZeros().toPlainString();
			if( s.startsWith("0") )	System.out.println( s.substring(1) );
			else	System.out.println( s );
		}
	}
}


BigInteger 高精度整数类, 可以建立高精度整数对象.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 输入说明 The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9. 输出说明 The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer. 输入样例 95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12 输出样例 548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201 小提示 If you don't know how to determine wheather encounted the end of input: s is a string and n is an integer C++ while(cin>>s>>n) { ... } c while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want /*while(scanf(%s%d",s,&n)!=EOF) //this also work */ { ... } 来源 East Central North America 1988 北大OJ平台(代理
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值