| ||||||||||
Online Judge | Problem Set | Authors | Online Contests | User | ||||||
---|---|---|---|---|---|---|---|---|---|---|
Web Board Home Page F.A.Qs Statistical Charts | Current Contest Past Contests Scheduled Contests Award Contest | wilson1068 Log Out Mail:0(0) Login Log Archive |
Language:
Dividing
Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input
Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000.
The last line of the input file will be "0 0 0 0 0 0"; do not process this line. Output
For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.".
Output a blank line after each test case. Sample Input 1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0 Sample Output Collection #1: Can't be divided. Collection #2: Can be divided. Source |
[Submit] [Go Back] [Status] [Discuss]
All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator
DP:多重背包
可以使用混合的 01背包和完全背包
我这里使用的是把多重背包通过二进制拆成01背包,
然后用解01背包的方法解的。。。
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define MAXN 60100
int f[MAXN], n[7], v[200], len;
int money;
void birth_goods(){
len = 0;
for(int i=1; i<=6; i++)
for(int j=0; n[i]; j++)
if( n[i]>=(1<<j) ){
v[len] = (1<<j)*i;
len ++;
n[i] -= (1<<j);
}
else{
v[len] = n[i]*i;
len ++;
n[i] = 0;
}
}
int main(){ freopen("1014.in", "r", stdin);
int no = 1;
while( 1 ){
money = 0;
for(int i=1, x; i<7; i++){
scanf("%d", &x);
n[i] = x;
money += x*i;
}
if( !money ) break;
printf("Collection #%d:\n", no++);
if( money&1 ){
printf("Can't be divided.\n\n");
continue;
}
memset(f, 0, sizeof(f));
birth_goods();
money >>= 1;
int ans = 0;
for(int i=0; i<len; i++){
for(int j=money; j>=v[i]; j--){
f[j] = max(f[j], f[j-v[i]]+v[i]);
}
}
printf("%s be divided.\n\n", f[money]==money ? "Can":"Can't");
}
return 0;
}