20140719 「线段树 - 区间更新,区间求和」 POJ 3468 A Simple Problem with Integers

10 篇文章 0 订阅
6 篇文章 0 订阅

Online JudgeProblem SetAuthorsOnline ContestsUser
Web Board
Home Page
F.A.Qs
Statistical Charts
Problems
Submit Problem
Online Status
Prob.ID:
Register
Update your info
Authors ranklist
Current Contest
Past Contests
Scheduled Contests
Award Contest
wilson1068      Log Out
Mail:0(0)
Login Log      Archive
Language:
A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 58536 Accepted: 17827
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator




无语了,把 main 函数第3行写成

“ wiile( ~scanf("%d", &T) ) { } ”;

结果 WA 了无数遍;


改成:

“ wiile( EOF != scanf("%d", &T) ) { } ”;

就行了。


可恶 >_< 




#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define MAXN 100100
typedef long long LL;
LL sum[MAXN<<2], add[MAXN<<2];
int a[MAXN];

void push_up(int rt){
    sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}

void push_down(int rt, int m){
    if( add[rt] ){
        add[rt<<1] += add[rt];
        add[rt<<1|1] += add[rt];
        sum[rt<<1] += (m-(m>>1)) * add[rt];
        sum[rt<<1|1] += (m>>1) * add[rt];
        add[rt] = 0;
    }
}

void build(int rt, int l, int r){
    add[rt] = 0;
    if( l==r ){
        sum[rt] = a[l];
        return ;
    }
    int mid = (l+r)>>1;
    build(rt<<1, l, mid);
    build(rt<<1|1, mid+1, r);
    push_up(rt);
}

void updata(int rt, int l, int r, int x, int y, int p){
    if( x<=l && r<=y ){
        add[rt] += p;
        sum[rt] += (LL)(r-l+1)*p;
        return;
    }
    push_down(rt, r-l+1);
    int mid = (l+r)>>1;
    if( x<=mid )    updata(rt<<1, l, mid, x, y, p);
    if( mid<y )     updata(rt<<1|1, mid+1, r, x, y, p);
    push_up(rt);
}

LL query(int rt, int l, int r, int x, int y){
    if( x<=l && r<=y )
        return sum[rt];
    push_down(rt, r-l+1);
    int mid = (l+r)>>1;
    LL r1=0, r2=0;
    if( x<=mid )    r1 = query(rt<<1, l, mid, x, y);
    if( mid<y )     r2 = query(rt<<1|1, mid+1, r, x, y);
    return r1+r2;
}

int main(){       
    int n, m, x, y;
    LL p;
    while( EOF != scanf("%d%d", &n, &m) ){
        for(int i=1; i<=n; i++)
            scanf("%d", &a[i]);
        build(1,1,n);
        char s[11];
        while( m-- ){
            scanf("%s%d%d", s, &x, &y);
            if( 'Q'==s[0] ) printf("%lld\n", query(1,1,n,x,y));
            else if( 'C'==s[0] ){
                scanf("%d", &p);
                updata(1,1,n,x,y,p);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值