20140911 【 初等数论 】 poj 2262 Goldbach's Conjecture

14 篇文章 0 订阅
10 篇文章 0 订阅

Online JudgeProblem SetAuthorsOnline ContestsUser
Web Board
Home Page
F.A.Qs
Statistical Charts
Problems
Submit Problem
Online Status
Prob.ID:
Register
Update your info
Authors ranklist
Current Contest
Past Contests
Scheduled Contests
Award Contest
wilson1068      Log Out
Mail:0(0)
Login Log      Archive
Language:
Goldbach's Conjecture
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37916 Accepted: 14588

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 
written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator





这题没什么好讲的,

只是为了记录一下压缩形式的素数筛选。

毕竟在C++中 bool 类型也是占一个字节的。

挺浪费空间。

改用位标记,可以压缩8倍空间。。


当然,时间上还是没有优化。。

(至于额外的时间花费??  要相信位运算的力量)






#include <iostream>
#include <algorithm>
using namespace std;
#define MAXN 1000000
char prime[MAXN/7];
int p[MAXN+10];
int np, n;
void init(){
    prime[0] = 3;
    np = 0;
    for(int i=2; i<MAXN; i++)
        if( !( prime[i>>3]&(1<<(i&7)) ) ){
            p[np++] = i;
            for(int j=i*i; j<MAXN; j+=i)
                prime[j>>3] |= 1<<(j&7);
        }
}

int main(){
    init();
    while( cin>>n && n ){
        int mid = np>>1|1, i, f;
        for(i=0; i<mid; i++){
            f = upper_bound(p, p+np, n-p[i]) - p-1;
            if( f>=0 && p[i]+p[f]==n )    break;
        }
        if( i!=mid )    cout<<n<<" = "<<p[i]<<" + "<<p[f]<<endl;
        else            cout<<"Goldbach's conjecture is wrong."<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值