hdu 2001 java/c++ 计算两点间的距离

Problem Description 输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。

Input 输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。

Output 对于每组输入数据,输出一行,结果保留两位小数。

Sample Input 0 0 0 1
0 1 1 0

Sample Output 1.00
1.41

java代码:

package aa;

import java.util.*;

public class Main
{
    public static void main(String []args)
    {
         Scanner cin=new Scanner(System.in);
         while(cin.hasNext())
         {
             double a=cin.nextDouble();
             double b=cin.nextDouble(); 
             double c=cin.nextDouble();
             double  d=cin.nextDouble();
             double s=Math.sqrt((a-c)*(a-c)+(b-d)*(b-d));
             System.out.format("%.2f",s).println();
         }

    }
}

c++代码:


#include <cmath>
#include <cstdio>

int main(void)
{
    double x[2], y[2];

    while (scanf("%lf%lf%lf%lf", x, y, x+1, y+1) != EOF)
        printf("%.2f\n", sqrt((x[1]-x[0])*(x[1]-x[0]) + (y[1]-y[0])*(y[1]-y[0])));

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值