Poj 1196

Lowest Bit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11797 Accepted Submission(s): 8581

Problem Description

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing “0” indicates the end of input, and this line is not a part of the input data.

Output

For each A in the input, output a line containing only its lowest bit.

Sample Input
26
88
0

Sample Output
2
8

题意:给出一个整数,化为2进制,找出最低位,再转化为十进制数
如88(101 1000)最低位=8(1000

import java.util.Scanner;

public class Main {
    //最低位方法
    public static int lowBit(int a){
        int num[] = new int[100];
        int flag = 0;
        do{
            num[flag] = a%2;
            if(num[flag] ==1) break;
            a /= 2;
            flag ++;
        }while(a!=0);
        int res = 0;
        for(int i=0;i<=flag;i++)
            res = res + num[i]*power(2,i);
        return res;
    }
    //幂方法
    public static int power(int a,int b){
        if(b ==0) return 1;
        int res = 1;
        for(int i=1;i<=b;i++)
            res *=a;
        return res;
    }

    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        while(in.hasNext()){
            int num = in.nextInt();
            if(num == 0) break;
            int res = lowBit(num);
            System.out.println(res);
        }

    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值