Constructing Roads

33 篇文章 0 订阅
5 篇文章 0 订阅

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17231
Accepted Submission(s): 6547

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output
179

WA的都无奈了,其中一个原因就是没让它循环输入,汗,以后注意,细心细心。。。

#include<stdio.h>
#include<algorithm>
using namespace std;
int per[120],n,p[120][120];
struct stu
{
    int head,end,len;
}a[100000];
int cmp(stu a,stu b)
{
    return a.len <b.len ;
}
void init()
{
    for(int i=1;i<=n;i++)
        per[i]=i;
}
int find(int x)
{
    int r=x;
    while(r!=per[r])
        r=per[r];
    per[x]=r;
    return r;
}
int join(int a,int b)
{
    int fa=find(a);
    int fb=find(b);
    if(fa!=fb)
    {
        per[fa]=fb;
        return true;
    }
    return false;
}
int main()
{
    int i,j;
    while(~scanf("%d",&n))//循环输入,不然一直WA
    {
        int m,k=0,sum=0;
        for(i=1;i<=n;++i)
        {
            for(j=1;j<=n;++j)
                scanf("%d",&p[i][j]);
        }
        for(i=1;i<n;i++)
        {
            for(j=i+1;j<=n;j++)//省时
            {
                a[k].head =i;
                a[k].end =j;
                a[k].len =p[i][j];
                k++;
            }
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d%d",&a[k].head ,&a[k].end );
            a[k].len =0;
            k++;
        }
        sort(a,a+k,cmp);//k初值为0,所以不能写成sort(a+1,a+k,cmp)
        init();
        for(i=0;i<k;++i)//从0开始
        {
            if(join(a[i].head,a[i].end))
            {
                sum+=a[i].len;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值