HDU 1086 You can Solve a Geometry Problem too (判断线段相交)

You can Solve a Geometry Problem too
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9956 Accepted Submission(s): 4929

Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point.

Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the number of intersections, and one line one case.

Sample Input

2
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.00
3
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.000
0.00 0.00 1.00 0.00
0

Sample Output

1
3

题解:

判断两条线段是否相交。
属于计算几何的基础题,分为两部,1:快速排斥检验,即以直线为对角线构造矩形,如果矩形不相交,那么两条线段一定不相交。判断公式为直线1的两个点的最大的x大于直线2的两个点的最小的x,同时直线2的最大的x大于直线1的两个点的最小的x。这样就在x轴的方向上保证了矩形相交,同理在y轴方向上也这么判断一下。2:跨立检验,即判断直线2的两个点是否在直线1的左右两边,直线1的两个点是否在直线2的两边。

AC代码如下:

#include <iostream>
#include <cstdio>
#define eps 0.0000001
using namespace std;

struct po{ // point
    double x,y;
    po(){}
    po(double _x,double _y){x = _x;y = _y;}
    po operator -(po p2) {
        return po(x-p2.x,y-p2.y);
    }
    double operator * (po p2){
        return x*p2.y - p2.x*y;
    }
};

struct line{
    po p1,p2;
}l[110];

bool judge1(line l1,line l2){ // 快速排斥检验
    return ( max(l1.p1.x,l1.p2.x) >= min(l2.p1.x,l2.p2.x) && max(l2.p1.x,l2.p2.x) >= min(l1.p1.x,l1.p2.x) && max(l1.p1.y,l1.p2.y) >= min(l2.p1.y,l2.p2.y) && max(l2.p1.y,l2.p2.y) >= min(l1.p1.y,l1.p2.y) );
}
bool judge2(po p1,po p2,po p3,po p4){// 跨立检验
    double m = (p2 - p1) * (p3-p1);
    double n = (p2 - p1) * (p4-p1);

    double mm = (p4 - p3) * (p2 - p3);
    double nn = (p4 - p3) * (p1 - p3);
    if(m * n <= 0 && mm*nn <= 0) return true;
    return false;
}
int main()
{
    int n;
    while(cin>>n,n){
        for(int i = 0;i < n;i++){
            scanf("%lf%lf%lf%lf",&l[i].p1.x,&l[i].p1.y,&l[i].p2.x,&l[i].p2.y);
        }

        int ans = 0;
        for(int i = 0;i < n;i++){
            for(int j = i+1;j < n;j++){
                if(judge1(l[i],l[j]) && judge2(l[i].p1,l[i].p2,l[j].p1,l[j].p2))ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值