POJ-3278-Catch That Cow(BFS)

Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 118888 Accepted: 37099

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

 

搜索入门,有坑点

#include <iostream>
#include <queue>
#include <algorithm>
#define MAX 100001
using namespace std;

queue <int> Q;
int dist[MAX];

int BFS ( int n, int k )
{
    Q.push( n );

    fill( dist, dist+MAX, 0);
    dist[n] = 1;
    while( !Q.empty() )
    {

        int v = Q.front();
        Q.pop();
        if( v == k )
            break;
        if( 2*v <= MAX && !dist[2*v] )  //坑点:不能写成  !dist[2*v] && 2*v <= MAX
        {

            dist[2*v] = dist[v] + 1;
            Q.push( 2*v );
        }
        if( v+1 <= MAX && !dist[v+1] )
        {

            dist[v+1] = dist[v] + 1;
            Q.push( v+1 );
        }
        if( !dist[v-1] && v-1 >= 0 )
        {

            dist[v-1] = dist[v] + 1;
            Q.push( v-1 );
        }
    }
    return dist[k]-1;
}


int main()
{
    int n, k;
    while(cin >> n >> k)

    cout << BFS( n, k ) << endl;

    return 0;
}





 

若先判断  !dist[2*v] ,可能立刻造成数组越界;若先判断  2*v <= MAX 不成立的话可以将  !dist[2*v]  短路,不会越界

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值