poj3295Tautology 离散数学前缀表达式(栈+枚举)

poj3295:点击打开链接

Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13200 Accepted: 5031

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

【解析】:

离散数学,给出真值表,计算表达式,前缀表达式(详细搜索逆波兰式)。

根据真值表可知

Kwx : w&&x(即与运算)

Awx : w||x

Nw :  !w(即非运算)

Cwx:!w||x(即蕴含运算)

Ewx: w==x(及判断wx是否相等)


然后对pqrst五个变量枚举0和1,一共2的5次方种情况;

看是否每种情况都是值为1;


前缀表达式的计算:从后往前扫描,遇到运算符就进行运算。

【代码】:

#include<stdio.h>
#include<string.h>
#include<stack>

using namespace std;
stack<int> s2;
int a[1280];
char s[100000];
int calcu(char ch,int t1,int t2)
{
	if(ch=='K'){//&&运算
		return t1&&t2;
	}
	if(ch=='A'){//或 
		return t1||t2;
	}
	if(ch=='C'){//蕴含 
		return !t1||t2;
	}
	if(ch=='E'){//相等 
		return t1==t2;
	}
}
int main()
{
	while(scanf("%s",s),s[0]!='0')
	{
		while(!s2.empty())s2.pop();
		int ans=1;
		for(int i=0;i<32;i++){//枚举pqrst
			a['p']=i>>4;
			a['q']=i>>3;a['q']%=2;
			a['r']=i>>2;a['r']%=2;
			a['s']=i>>1;a['s']%=2;
			a['t']=i%2;
			int c=0;
			for(int j=strlen(s)-1;j>=0;j--)
			{
				if(s[j]>'a'){
					s2.push(a[s[j]]);
				}
				else if(s[j]=='N'){
					int temp=s2.top();s2.pop();
					s2.push(!temp);
				}
				else{
					int t1=s2.top();s2.pop();
					int t2=s2.top();s2.pop();
					s2.push(calcu(s[j],t1,t2));
				}
			}
			if(s2.top()==0){
				ans=0;break;
			}
		}
		if(ans) puts("tautology");
		else puts("not");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

雪的期许

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值