hdu 1312 BFS模板题


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input
   
   
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

Sample Output
   
   
45 59 6 13

#include<iostream>
#include<algorithm>
#include<cstring>
#include<vector>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#define inf 99999999
using namespace std;
int map[25][25];
bool visited[25];
int dx[4]={0,-1,0,1};
int dy[4]={-1,0,1,0};
struct node
{
    int x;
    int y;
    int pre;
}q[500];
int main()
{
    int n,m;
    while(cin>>m>>n)
    {
        if(m==0||n==0)
            return 0;
        int x1,y1;
        for(int i=0;i<=n-1;i++)
            for(int j=0;j<=m-1;j++)
        {
            char ch;
            cin>>ch;
            if(ch=='@')
            {
                x1=i;
                y1=j;
            }
            if(ch=='#')
                map[i][j]=1;
            else
                map[i][j]=0;
        }
    q[0].x=x1;
    q[0].y=y1;
    q[0].pre=-1;
    map[x1][y1]=1;
    int a=0,b=1;
    while(a<b)
    {

        for(int i=0;i<=3;i++)
        {
            int x0=q[a].x+dx[i];
            int y0=q[a].y+dy[i];
            if(x0>=0&&x0<=n-1&&y0>=0&&y0<=m-1&&!map[x0][y0])
            {
                q[b].x=x0;
                q[b].y=y0;
                q[b].pre=a;
                map[x0][y0]=1;
                b++;
            }
        }
        a++;
    }
    cout<<a<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值