SPOJ DISUBSTR-----后缀数组求串的子串的个数


Description

Given a string, we need to find the total number of its distinct substrings.

Input

T- number of test cases. T<=20;
Each test case consists of one string, whose length is <= 1000

Output

For each test case output one number saying the number of distinct substrings.

Example

Sample Input:
2
CCCCC
ABABA

Sample Output:
5
9

Explanation for the testcase with string ABABA: 
len=1 : A,B
len=2 : AB,BA
len=3 : ABA,BAB
len=4 : ABAB,BABA
len=5 : ABABA
Thus, total number of distinct substrings is 9.



每一个后缀,其会产生 n-sa[i] 个前缀,并且会有height[i]个与前一个相同。加入当前后缀增加的不同前缀数量为:  n-sa[i]+1 - height[i].   然后整个串的不同子串数量即为,所有前缀产生的总和。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#define inf 0x3f3f3f3f
#include<algorithm>
using namespace std;
const int MAX=1020;
int n,k;
int wa[MAX],wb[MAX],wsf[MAX],wv[MAX],sa[MAX];
int rank[MAX],height[MAX],r[MAX];
int cmp(int *r,int a,int b,int k){
    return (r[a]==r[b])&&(r[a+k]==r[b+k]);
}
void da(int *r,int *sa,int n,int m)//??N????N??1????????????????cmp???
{
    int i,j,p,*x=wa,*y=wb,*t;
    for(i=0;i<m;i++) wsf[i]=0;
    for(i=0;i<n;i++) wsf[x[i]=r[i]]++;
    for(i=1;i<m;i++) wsf[i]+=wsf[i-1];
    for(i=n-1;i>=0;i--) sa[--wsf[x[i]]]=i;
    for(j=1,p=1;p<n;j*=2,m=p)
    {
        for(p=0,i=n-j;i<n;i++) y[p++]=i;
        for(i=0;i<n;i++) if(sa[i]>=j) y[p++]=sa[i]-j;
        for(i=0;i<n;i++) wv[i]=x[y[i]];
        for(i=0;i<m;i++) wsf[i]=0;
        for(i=0;i<n;i++) wsf[wv[i]]++;
        for(i=1;i<m;i++) wsf[i]+=wsf[i-1];
        for(i=n-1;i>=0;i--) sa[--wsf[wv[i]]]=y[i];
        for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1;i<n;i++)
            x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
    }
}
void calheight(int *r,int *sa,int n)//??height??,

{
    int i,j,k=0;
    for(i=1;i<=n;i++)
        rank[sa[i]]=i; //????1~n?sa[]=(0~n-1)??
    for(i=0;i<n;i++)
    {
        if(k)  k--;
        else  k=0;
        j=sa[rank[i]-1];
        while(r[i+k]==r[j+k])
        k++;
        height[rank[i]]=k;
    }
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        string str;
        cin>>str;
        int len=str.length();
        for(int i=0;i<=len-1;i++)
            r[i]=str[i];
        n=len;
        r[n]=0;
        da(r,sa,n+1,128);
        calheight(r,sa,n);
        int ans=0;
        for(int i=1;i<=n;i++)
            ans+=n-sa[i]-height[i];
        cout<<ans<<endl;
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值