poj 1328 区间,贪心


        Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1

给定海岛个数、雷达半径以及各海岛坐标,求能覆盖所有海岛的最小雷达数。

贪心策略依然是从左往右,尽量让每颗雷达覆盖最大岛屿数。

对于每个点先求出以该点为圆心,d为半径的圆在x轴上的交点,左右交点就是覆盖此海岛的雷达所在的区间。

对于每个区间,按照区间的右端点排序。

从最左边开始贪心,对于第一个右端点x0,所有左端点<x0的海岛都会与x0共用一个雷达

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
struct node
{
    int x,y;
}q[1010];
struct xnode
{
    double l,r;
}xn[1010];
bool cmp(xnode a,xnode b)
{
    if(a.r==b.r)
        return a.l<b.l;
    return a.r<b.r;
}
bool visited[1010];
int main()
{
    int n,d;
    int kcase=1;
    while(cin>>n>>d)
    {
        if(n==0)
            return 0;
        bool flag=0;
        for(int i=1;i<=n;i++)
        {
            cin>>q[i].x>>q[i].y;
            if(q[i].y>d)
                flag=1;
        }
        if(flag==1||d==0)
        {
            cout<<"Case "<<kcase++<<": "<<-1<<endl;
            continue;
        }
        for(int i=1;i<=n;i++)
        {
            double len=sqrt(1.0*d*d-q[i].y*q[i].y);
            xn[i].l=q[i].x-len;
            xn[i].r=q[i].x+len;
        }
        sort(xn+1,xn+n+1,cmp);
        int ans=0;
        memset(visited,0,sizeof(visited));
        for(int i=1;i<=n;i++)
            if(!visited[i])
        {
            visited[i]=1;
            ans++;
            for(int j=i+1;j<=n;j++)
                if(!visited[j]&&xn[j].l<=xn[i].r)
                    visited[j]=1;
        }
         cout<<"Case "<<kcase++<<": "<<ans<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值