Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.Output
One integer per line representing the maximum of the total value (this number will be less than 231).
Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1Sample Output
14Sponsor
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
const int N=1100;
int v[N],w[N];
int f[N];
int n,m;
int main()
{
int t;cin>>t;
while(t--){
cin>>n>>m;
memset(f,0,sizeof(f));
for(int i=1;i<=n;i++)
{
cin>>w[i];
}
for(int j=1;j<=n;j++)
{
cin>>v[j];
}
for(int i=1;i<=n;i++)
{
for(int j=m;j>=v[i];j--)
{
f[j]=max(f[j],f[j-v[i]]+w[i]);//1 G++提交
}
}
cout<<f[m]<<endl;
}
return 0;
}