解题报告_POJ1979-red and black_深搜水题

POJ 1979 red and black

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he cant move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

    1
    2
    3

The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output

45
59
6
13

出现过一个令我费解的错误, 程序运行过程中总是出错误
调试之后发现, 因为没有给走过的点特判一下, 导致走来走去结束不了

题目原文因为markdown 原题出现的 # 会把后面的字作为标题, 所以不得不用代码块来引用

AC代码:

#include <iostream>

using namespace std;

void search(char map[][21], int x, int y, int m, int n, bool ma[][21])
{
    if(x == 0 || y == 0 || x > m || y > n || map[x][y] == '#' || ma[x][y]) {
        return;
    } else {
        ma[x][y] = 1;
        search(map, x-1, y, m, n, ma);
        search(map, x+1, y, m, n, ma);
        search(map, x, y-1, m, n, ma);
        search(map, x, y+1, m, n, ma);
    }
}

void loop(int m, int n) {
    char map[21][21] = {};
    bool ma[21][21] = {};
    int x = 0, y = 0, ans = 0;
    for( int i = 1; i <= m; ++i ) {
        for( int j = 1; j <= n; ++j ) {
            cin >> map[i][j];
            if(map[i][j] == '@') {
                x = i;
                y = j;
            }
        }
    }
    search(map, x, y, m, n, ma);
    for( int i = 0; i <= 20; ++i ) {
        for( int j = 0; j <= 20; ++j ) {
            if( ma[i][j] ) ans++;
        }
    }
    cout << ans << endl;
}

int main()
{
    int m, n;
    while( cin >> m >> n && m ) {
        loop(n, m);
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值