GDUT - 专题学习1 A - Red and Black

A - Red and Black

题目

        There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.


        Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

        The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

        There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

        '.' - a black tile
        '#' - a red tile
        '@' - a man on a black tile(appears exactly once in a data set)
        The end of the input is indicated by a line consisting of two zeros.

Output

        For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

大致题意

        输入两个正整数W和H,再给出一个W×H的二维字符数组,其中 '.' 代表黑色瓷砖,'#' 代表红色色瓷砖,'@' 代表人目前所在位置,人可以移动到相邻的四块黑色瓷砖上,但不能移动到红色瓷砖上。求该人最多可以到达的黑色瓷砖的数量。

思路

        首先我们可以在输入二维字符数组的时候就找到 ‘@’ 的所在坐标,接着再将该坐标放入dfs中搜索与其联通的 ‘.’ ,将所有与 ‘@’ 联通的 ‘.’ 全部变为 除了以上三种字符 的任意字符,在这里我是将其变为 '!' ,注意人只能上下左右的走,不能斜着走。最后再统计一遍 '!' 的数量即可。

代码

#include<iostream>
using namespace std;
int n, m, xp, yp, ans;
char a[25][25];
void dfs(int x, int y)
{
	if (x<0 || y<0 || x>n || y>m)
	{
		return;
	}
	if (a[x][y] == '.' || a[x][y] == '@')//在这里我顺便把‘@’也一起处理了
	{
        //先将合法的位置变为‘!’
		a[x][y] = '!';
        //将此位置的上下左右都遍历一遍
		dfs(x - 1, y);
		dfs(x + 1, y);
		dfs(x, y - 1);
		dfs(x, y + 1);
	}
	return;
}
int main()
{
	while (1)
	{
		ans = 0;
		cin >> m >> n;
		if (!n && !m)//结束条件判断,如果n==0并且m==0就结束输入
		{
			break;
		}
        //注意每次输入都要将二维字符数组a给重置一下,否则上次输入的数据可能会影响到这次的结果
		for (int i = 0; i < 25; ++i)
		{
			for (int j = 0; j < 25; ++j)
			{
				a[i][j] = '#';
			}
		}
		for (int i = 0; i < n; ++i)
		{
			for (int j = 0; j < m; ++j)
			{
				cin >> a[i][j];
				if (a[i][j] == '@')
				{
					xp = i, yp = j;//记录‘@’的坐标
				}
			}
		}
		dfs(xp, yp);
		for (int i = 0; i < n; ++i)
		{
			for (int j = 0; j < m; ++j)
			{
				if (a[i][j] == '!')//统计数量
				{
					++ans;
				}
			}
		}
		cout << ans << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值